SOLIDWORKS操作マニュアル

スイープのための平面作成

こんにちは、アドライズの五味です。 すっかり春らしい暖かさを感じられるようになりましたね。 暖かいと眠くなってしまうものですが、眠気に負けず、 今日も元気にSOLIDWORKSを勉強していきたいと思います! さて、本日勉強するテーマは「スイープのための平面作成」です。 書籍に関してお問い合わせをいただいた問題ですが、 せっかくなので皆様と共有していきたいと思います。 今日は『3次元CAD SolidWorks練習帳』の81Pに掲載されているカム軸をモデルに使用します。 (モデルデータはこちらの応用問題にあります) 解答モデルデータの履歴を確認すると、平面2がオレンジ色で表示された平面1より少し傾いています。 また、この平面1も最初からある平面ではありません。 このカム軸の溝は「スイープカット」フィーチャーを使用しています。 円筒面に沿って溝を掘るため、「ヘリカルカーブ」を軌跡とし、 カーブの端点に対して垂直な平面2に描写したスケッチを輪郭としてスイープカットしています。 平面1、並びにカーブの端点に対して垂直な平面2とはどうやって作成するのでしょうか? 綺麗なモデルを作成するため、新しい平面の作成方法を学んでいきましょう! ステップ1『平面1の作成』 カム軸の溝は下図のように、緑色に表示された面から 10mmほど離れたところから始まります。 よってカム軸の円筒面に沿ったヘリカルカーブも、 緑色の面から10mm離れたところから描写を始める必要があります。 まずはそのための平面を作成してみましょう! フィーチャータブの『参照ジオメトリ』→『平面』を選択。 第一参照にピンクで表示されているモデルの面を選択し、距離を10mmとしてOKをクリック。 するとピンクの面を基準に10mmオフセットした平面が作成されます。 この平面1に、ヘリカルカーブの元となる円のスケッチを描きます。 必要なのはカム軸の円筒面と同じ円のスケッチです。 今回はエンティティ変換を使って円のスケッチをトレースしましょう。 平面を選択→スケッチを開始し、下図のエッジを選択。 スケッチタブから『エンティティ変換』コマンドをクリック。 すると下図のように円筒のエッジが平面1に投影されます。 ここを起点にヘリカルカーブを作成します。 フィーチャータブから、『カーブ』→『ヘリカルとスパイラル』を選択。 下図のようにパラメータを設定してヘリカルカーブを作成しましょう。 ステップ2『ヘリカルカーブに合わせた平面の作成』 フィーチャータブから『参照ジオメトリ』→『平面』を選択。 ヘリカルカーブとヘリカルカーブの端点を参照します。 OKをクリックすると、平面2が作成できます。 こうして新しく作成した平面2に溝を掘るためのスケッチを描いていきましょう。 平面2を選択し、『矩形中心』を使って下図のスケッチを描きます。 この矩形の中心の点とヘリカルカーブを選択し、『貫通』の拘束をつけます。 拘束がついたら、スケッチを終了しておきます。 あとは、フィーチャータブから『スイープカット』を選択し、 青い欄(輪郭)に先ほど描いた矩形のスケッチを、 ピンクの欄(パス)にヘリカルカーブを指定し、OKをクリックします。 仕上げとして溝の両端を丸めましょう。 『フィレット』を選択、『ラウンドフィレット』にチェックを入れ、 下図のように面を選択します。 反対側も同様にしてフィレットを行うことで、 カム軸の溝のモデル作成ができました! いかがでしたでしょうか? 実は平面2を作成せず、平面1に矩形を描写し、 同じような手順を踏んでも溝を掘ることはできます。 一見すると似たような溝が掘れているように思えるのですが、 測定してみると平面2を作成しなかった場合は歪んでしまっているのがわかります。 興味のある方はぜひ一度、平面2を作成せずに溝を掘り、 それがどのように歪んでしまっているのか測定してみてくださいね。...

プロパティのコピー方法

初めまして、アドライズの五味です。 今度から私もSOLIDWORKSを勉強していきたいと思いますので、 どうぞよろしくお願いします。 さて、初めての投稿となる本日のテーマは 『プロパティのコピー方法』 についてです。 【プロパティとは?】 品名や図番、材質などの情報が入っているものです。 確認するには、部品のファイルを開いた状態で画像の上のアイコンをクリック。 すると、下図のように部品ファイルのプロパティが確認できます。 (モデル、プロパティは参考です) 通常は最初にプロパティ情報を入れてテンプレートにした ドキュメントで作成し始めることも多いと思いますが、 ・テンプレートを使用しなかった ・後から情報が加わった、変更になった というような場合もありますよね。 例えば下図のようにプロパティの情報がない場合 この部品にもさっきと同じプロパティの記載をしたい…! そんな時の操作方法をご紹介します。 ①プロパティ記述の選択 一番左のナンバリングされている列にカーソルを持っていくと、 下図のように変化します。 この状態でドラッグすることでプロパティの行を選択することができます。 反転して選択状態になっている時に、 コピーのショートカットコマンドを入力。(Ctrl+C) OKを押してプロパティ表示を閉じましょう。 ②プロパティ記述の貼り付け プロパティを上書きしたい部品のファイルを開き、 プロパティを表示しましょう。 一番左のナンバリングされている列をクリックすることで選択状態にします。 今度は、貼り付けのショートカット(Ctrl+V)をキーボード入力。 すると… さきほどコピーしたプロパティの内容が上書きされます! 【!注意!】プロパティを上書きしたい場合 プロパティ名が重複するとエラーになってしまうので、 『各項目ごとにコピー&ペーストをする』 『項目をすべて削除して、すべて上書きしなおす』 のどちらかでプロパティを変更しましょう。 いかがでしたか? 普通なら右クリックでコンテキストメニューが表示されますが、 SOLIDWORKSでは表示されないため このような手順でのコピー&ペーストとなります。 ぜひ、お手持ちの部品ファイルのプロパティについて、 コピー&ペーストを試してみてください。...

表示方向の新規作成方法

こんにちは。アドライズの中澤です。 久しぶりの配信となり 申し訳ございません。 最近おかげ様で忙しくさせていただき、 実務に少し携わっておりました。 折角なので、そこで得た知識も ご紹介していきたいと思ってます。 早速、図面の端に表示するモデルについて、 通常は不等角投影などで表示させておくことが 多いと思いますが、 「もうちょっと回転させて後側が見えるようにしたい」 とか、 「裏側から見た図にしたいけど、その表示方向がない」 などと困ることはありませんか? ということで、今回は、 個別で表示方向を設定したビューの作り方をご紹介します。 ※向きなど分かりやすいよう弊社書籍(よくわかるSOLIDWORKS演習)より クジラを使用しております。 青枠で表示されている部分、 右側面図から斜めに引き出したところ、 くじらがそっぽ向いてしまいました。 こちらに向けて見ましょう。 ちなみにこのモデルは不等角投影にするとこのようになります。 ですから、不等角投影に差し替えてみましょう。 レイアウト表示>モデルビュー 出てきた左側のモデルビューのメニューから 矢印ボタンで「次へ」へ 表示方向の選択画面より「不等角投影」をクリックして マウスをグラフィック領域にずらします。 こちらを向いたクジラがでてきました。 そっぽ向いたのは削除し、こちらを配置しましょう。 さらに。 もう少し角度を変えた表示させたいという場合は、 今ある表示方向からはできません。 新規で表示ビューを作成しましょう。 ここからは部品ドキュメントに移ります。 マウスホイールや矢印キーなどを使ってモデルを 回転させ、良い角度を決めてください。 キーボードの入力を半角入力の状態で、「スペース」キーを押すと 表示方向のウィンドウが出ます。 ↑画像のように新表示方向をクリック。 表示方向名として、その表示に名前をつけておきます。 (今回は「図面用」としました) OKを押すと、図面用というビューが完成しました。 保存しておきます。 図面ドキュメントにもどります。 先ほど不等角投影にした表示方向のところを見ると。。。 新たに図面用のビューが追加されています。 完成です。 如何でしたか? 部品によっては色々な向きで作成されていると 回転する必要のあるものも出てくるかもしれません。 ぜひ分かりやすい角度で表示してみてくださいね。 ...

【訂正】書籍『実践SolidWorks』の誤画像について【104P】

書籍『実践SolidWorks』の104Pについて 誤画像がありましたので訂正をさせていただきます。   手順②において「ミラー」コマンドの 設定する内容に誤りがあります。   上記の画像で上から4つ目の矢印の項目 フィーチャーのスコープで選択するボディが 「タイロッド」となっております。 正しくはスイープ1となります。 (タイロッドはその先の手順⑤で変更する名前ですので  手順②の時点ではスイープ1です) 誤:タイロッド 正:スイープ1 フィーチャーのスコープに、 履歴から「スイープ1」のボディを 選択していただけますようお願いします。     ご迷惑をおかけいたしましたことを深くお詫び申し上げます。...

パック&ゴーって何?

おはようございます。 アドライズの中澤です。   会社内で飛び交う会話について 先日、「それ何?」というものがあったのでシェアします。   【パック&ゴー】 「それをパック&ゴーして」 「パック&ゴーしたの?」 というような会話が設計者やCADオペレーターの間でされていました。 実務にいない私には聞きなれない言葉だったので 解説してもらいました。   パック&ゴーとは、 SOLIDWORKSは部品やアセンブリ、図面など、複数のドキュメントやファイルを 作成していきますが、お互いに関係性があります。 例えば、アセンブリは部品ドキュメントを参照しています。 図面も作成した部品ドキュメントに依存して作成されます。   ですから、別案件で以前作ったのと同じようなの使いたいなーって 単純にそのアセンブリドキュメントだけコピーしてきてもエラーになる可能性が ものすごく高いのです。   そこで、【パック&ゴー】の出番。 このコマンドで、関連する全てのファイルをコピーして複製してくれます。     ** 操作手順 ** ①コピーしたいファイルを開いて ファイル>パック&ゴー   ②出てきたメニューより保存するファイルや保存先を指定>保存     操作はこれだけです。 実務をしていないとなかなか行うことの無い機能かと思いますが、 沢山使用するものなので、知らなかった方は言葉だけでも覚えてみてくださいね。    ...

便利に使いこなせ!マウスジェスチャー

今日ご紹介するのはコレ↓ ↓ ↓ 見たことありますか? 「マウスジェスチャー」という機能です。 グラフィックス領域で右クリックしたまま任意方向にドラッグすると、これがカーソルの周りに出現します。 カーソルを上下左右に移動させることでメニューを選ぶことができます。 上記は4メニューですが、8メニューに設定することも可能です。 図面、部品、アセンブリ、またはスケッチで、ツールまたはマクロを呼び出すことができます。 デフォルトでは表示方向を中心に設定されています。 スケッチ編集中のマウスジェスチャーはこちら↓ ↓ ↓ 例えばスケッチ編集中には スケッチを描いて、寸法を入れて・・・という動作が 都度画面左上のコマンドボタンを押しにいきますよね。 でも、このマウスジェスチャーを使えば、モデルからカーソルをちょっと外した グラフィックス領域で少しだけドラッグするだけで、よく使うスケッチの 直線、円、矩形等を描くモードにすぐ入れます。 描き終わったらマウスジェスチャーの上側にあるスマート寸法で 寸法も入れられます。 つまり、マウス動作が最小限に抑えられます。     でも、このメニュー使いにくいなぁ。。 こんなのあってもあんまり便利にならないなぁと感じる方もいると思います。 設定が出来ます! ツール→ユーザ定義 マウスジェスチャーというタブがあります。 この画面から設定します。 右上でメニューの数が4か8動作かを選べます。 部品・アセンブリ・図面・スケッチのそれぞれの状態で出るメニューを選べます。 出したいコマンドを探し、そのマスにカーソルを合わせると三角ボタンがでるのでクリック。 設定したい方向を選択しておきます。   いかがでしたか? マウス移動の僅かな距離を短縮させるだけといえばだけのコマンドですが、 この使用に慣れると 「ものすごく便利で他の端末使った時に出てこないと使いにくくてしょうがない」 という感想も出ていました。 よく使うメニューなど、自分なりの設定で使用してみてくださいね。   最後に設定すると便利かもしれないコマンド (実際に使用している設計者に聞きました)を下記にご紹介します。 ・部品 穴ウィザード、スケッチ、測定、選択アイテムに垂直 など ・アセンブリ 測定、左側面、右側面、選択アイテムに垂直 など ・図面 モデルの挿入、直線、円、スマート寸法 など ・スケッチ 押し出し、押し出しカット、スマート寸法、選択アイテムに垂直 など    ...

モデリングの方法色々

こんにちは。アドライズの中澤です。   久しぶりの投稿になってしまいました。 私たちはこの夏、数人の大学生をインターンシップ生として 迎えておりました。   実務を体験していただきましたが、 どの学生さんも学校などですでにSOLIDWORKSは 使えるようになっている優秀な方ばかり。 でも、一応お伝えするにあたりレベルチェックは させて頂きたい、と最初に練習問題を出題させていただきました。   そこで、学生さんたちにお伝えさせていただいた内容が 好評でしたので、ここでもお伝えさせていただきたいと思います。     かなり簡易な形にしていますが、皆さんだったらこの形、 どんなアプローチで作成しますか? 色々なやり方があると思います。 学生さんがやってた方法や弊社が推奨する方法を混ぜて、 まずは3択。あなたならどれで作りますか?   方法1:断面形状を作って回転で作成 方法2:頭と胴体を別々のフィーチャーで作成 方法3:全体の形を作ってから削る   では、1つづつ見ていきましょう。 ※その形が出来ていることには違いが無いので どれも間違いではないことを先にお伝えさせてください。 ここでは、より効率的であったり、シンプルで分かりやすく、 設計変更がしやすいという、実務に向いた設計手法として 弊社の推奨するやり方をご案内させて頂いております。 方法1:断面形状を作って回転で作成 円形の形状の場合の作成手順としては、 このやり方を取られる方も多いのではないかと思いますが、 これだと形状が複雑である場合に応用が利きにくいため、 今回のような単純形状以外には向いていないと考えられます。 設計変更が生じた場合、どこか1箇所でも寸法を 変えただけで他のところまで変えなくてはいけなくなる可能性があり、 制御が難しくなる方法といえるからです。   方法2:頭と胴体を別々のフィーチャーで作成 2つのフィーチャーがくっついている形状にも見えるので このような作成を選ぶ場合もありますよね。 しかし、実際の加工を考えたらどうでしょうか。 2つの塊をくっつけて作るということはしません。 また、図面を見ても、頭の部分の寸法は 記載されていません。 簡単に推測できる部分ではありますが、 図面どおりに作ることを考えた場合、 こういった方法も現実的ではないと言えます。 方法3:全体の形を作ってから削る アドライズがお勧めする手法が最後のコチラです。 最大の大きさのところで円筒形を作り、 そこからカット、カット、で形を作り上げていきます。 方法2でも少しふれましたが、実際の加工工程と 同じにしています。     完成した形だけを見ればどれも同じですが、 色々な作り方があります。 実際の現場では、設計変更や、複数人で作り上げるなど、 学生とは違う場面が多々あります。 誰が見ても分かりやすく、作りやすい形状であることも 大事な要素であると考えます。   ご参考になれば幸いです。                ...

【訂正】書籍『実践SolidWorks』の誤画像について

「実践SolidWorks」P74~77につきまして誤りがございましたので 訂正のご案内をさせていただきます。     P74までの操作で行った上記のようなカット後の画像におきまして、 カット後の形状に誤りのある画像が使われておりました。     <誤>  <正>     購入されているお客様には大変な混乱を 招きましたこと、誠に申し訳ございません。   下記に差し替えページを作成させていただきましたので お手数ではございますが、印刷の上差し替えをお願いいたします。     74~77Pの差し替えページ こちらからダウンロードください。  ...

パワートリム

「エンティティのトリム」の中から 【パワートリム】についてご説明します。 【パワートリム】はエンティティの トリムの中でも素早く不要な線を取り除ける機能です。 上のようなスケッチがあり外側の線だけが必要だとします。 内側の円弧と鉛直線が不必要なので切り取ります。 Command Managerから【エンティティのートリム】をクリックします。 オプションで【パワートリム】を選択します。 図のように切り取りたい線の上をまたぐようにドラッグします。 線をまたぐと同時に線が切り取られます。 続けてもう一つの線も切り取ります。 不必要な2本の線を切り取ることができました。 --------------------------------------- しかし、パワートリムの機能はこれだけではありません。 線を切り取るだけでなく、線を伸ばしてつなげることもできてしまうのです。 【パワートリム】は上のように開いた線を繋げることもできます。 開いた線の先端をクリックします。 繋げたいところまでドラッグします。 開いた線を繋げることができました。...

『階層リンク』で目的にすぐアクセス

今回はSOLIDWORKS2016からの新機能である 『階層リンク』についてご案内します。   部品ドキュメントやアセンブリドキュメントで使用できます。 ただ表示しただけでは『階層リンク』はまだありません。 (今回はアセンブリドキュメントでご案内しています)   変更や修正などをしたい、といじろうとするとき、 今までなら該当箇所をクリックし、左側のツリーからそのフィーチャーを 探しだし、修正画面に入りますよね。   しかし、新しいバージョンでは 変更や修正をしたい、と該当箇所をクリックすると 左上にメニューが現れます。 これが『階層リンク』です。↓ 下にあるスケッチをクリックすると ツリー内を探さなくてもすぐにスケッチ編集に入れます。   さらに上には、その該当部分に属する合致も表示されるので 合致の編集にもすぐにアクセスできます。     いかがですか? 便利ですよね。   2016以降を使用している方はぜひお試しください!...