実務ノウハウ

部品の動きを確認しよう ~制限合致②~

  前回に引き続き、【制限合致】のご紹介です。 第1弾はこちらから ↓ ↓ ↓ 部品の動きを確認しよう ~制限合致①~ https://cadrise.jp/qanda/limit-mates/   第2弾の今回は、 [サブアセンブリのフレキシブル化]です。 下図の前回のアセンブリを 最終組立となるアセンブリに挿入して 動きを確認します。 コンフィギュレーションとは違い 可動範囲もリアルにわかるのでとても便利です。       [サブアセンブリのフレキシブル化]   まず、2種類のアセンブリを用意します。 ①トップアセンブリ (装置全体の最終組立品のこと) ②サブアセンブリ (トップアセンブリを構成する組立品のこと) ※今回の②は前回で【制限合致】をつけたアセンブリを指します。   実際にサブアセンブリを挿入したトップアセンブリ   ところが・・・   サブアセンブリ作成時は 制限距離の範囲で動いたテーブルが、 トップアセンブリに挿入すると動きません。 これはサブアセンブリが“リジット”という 固定された状態だからです。   そこで、サブアセンブリを“フレキシブル”という 固定されていない状態にする必要があります。 ※SOLIDWORKSのデフォルト設定では、 トップアセンブリの中でサブアセンブリは 一つのユニットとして動作するため 固定される仕様です。   ツリーからサブアセンブリを右クリック。 コンテキストツールバーから 「サブアセンブリをリジットに指定」をクリックします。   すると・・・ サブアセンブリがフレキシブルになります。   ツリーをよく見るとフレキシブルに設定したアセンブリは、 アイコンが変わっています。 どのサブアセンブリがフレキシブルで 可動するのかすぐにわかりますね。     フレキシブルにしたことで、 サブアセンブリのテーブルは 制限合致で定義した可動域の範囲で移動します。     より具体的に動きを再現することができますね。 ぜひお試しください。    ...

部品の動きを確認しよう ~制限合致①~

  装置設計で機械の動きを表現する場合、 コンフィギュレーションを用いることがあります。 コンフィギュレーション機能は、 1 つのドキュメント内に 形状違いなど複数の部品やアセンブリモデルを作成できます。   例えばシリンダなどの装置設計で動きをみる際に コンフィギュレーションを用いた場合は 「最大」や「最小」といった特定の位置の状態を再現できます。 コンフィギュレーションの追加はこちらから https://cadrise.jp/manual/so_manual/%e3%82%b3%e3%83%b3%e3%83%95%e3%82%a3%e3%82%ae%e3%83%a5%e3%83%ac%e3%83%bc%e3%82%b7%e3%83%a7%e3%83%b3%e3%81%ae%e8%bf%bd%e5%8a%a0/     設計をするときに、 「実際の動きを確認しながら設計をしたい」 と思ったことありませんか? 今回ご紹介するコマンドを使用することで、 部品がどのように動くのかを表現することができます。 2回に渡ってご紹介する内容はこちら☟ 第1弾 【制限合致】 第2弾 【サブアセンブリのフレキシブル化】     今回は、設定をするにあたっての準備段階 【制限合致】 です。   まず、動きを持たせたいアセンブリを用意します。 今回は、テーブルが下記の設定で移動します。 ・テーブルの中心と下部品の端の移動量250mm 最小値:70mm(下部品端から) 最大値:320mm(下部品端から)   移動前(最小値)   移動後(最大値)       それでは、距離を制限した合致をつけましょう。 アセンブリタブ→「合致」コマンドをクリック。 合致設定に、図の2つ面を選択します。 「詳細設定合致」を展開し、「制限合致」をクリック。 距離に最小値:70mm(下部品端から)が選択されます。 最大値と最小値を設定します。 最大値:320mm(下部品端から) 最小値:70mm(下部品端から)   合致コマンドを終了します。 移動距離を制限した合致をつけることができました。   距離制限をつけたことにより テーブル可動域の範囲で移動します。     次回は、このアセンブリ部品を 実際の装置(トップアセンブリ)に挿入して動かします。 【サブアセンブリのフレキシブル化】 ご期待ください。...

簡単にねじ山のモデリングをする方法

ねじ山をリアルに見せたい時に どうやって3Dモデルで作成しようかと 悩んだことはありませんか。 作成するにしても ヘリカルとスパイラルコマンドで 螺旋を描きねじの谷スケッチを書き・・・ と大変だったかと思います。 そんな3Dモデルで ねじ山をリアルに作成するときに 便利なコマンドをご紹介いたします。 「ねじ山」 円筒形状に対してねじ山をモデリングできます。 (これはSOLIDWORKS2016からの機能です。)     メニューバー/挿入から、 「フィーチャー」→「ねじ山」をクリックします。     コマンドを実行すると 下図のようなアラートメッセージ現れます。 ※これは実際に加工する寸法が適用されたスケッチ輪郭ではないので、 3Dデータからの生産には用いないようにとのメッセージです。 OKをクリックします。   ねじ山コマンドが実行され、PropertyManagerが開きました。   今回は全ねじボルトを作成してみたいと思います。 まず、ねじ山を作成したいエッジを選択します。     選択するとプレビューが表示されます。     この時に、オフセットにチェックを入れ 距離を設定すると(場合によっては反対方向にチェック) モデル端までねじ山を作成することができます。     次に、押し出し状態を設定します。 今回は「次の選択まで」を選択し、六角ボルトの裏面を選択します。     選択するとプレビューが表示されます。   次にネジの仕様を設定します。 種類:「Metrir Die」 サイズ:「M4x0.7」 ねじ山の作成方法:「ねじ切り」にチェックを入れる   スクロールバーを下に移動して ねじ山のオプションを設定します。 「右ねじ」と「端面でトリム」にチェックを入れる       OKボタンをクリックすると、 ねじ山を作成することができました。   いかがでしたでしょうか。 簡単にねじ山を作成することができますね。     上記の方法でねじ山を作成したモデルを図面化すると、 作成された形状の通りに投影されるので実形図示になります。     図面でねじを通常図示したい場合は、 メニューバー/挿入から、 「アノテートアイテム」→「ねじ山」を使用してください。     こちらはネジ部を作成する方法でご紹介をしています。 https://cadrise.jp/manual/screwcreated/ あわせてご覧いただければ幸いです。    ...

3D CADデータを活用しよう ~3DPDF~

  3Dモデルは、製品の形状や構造を 視覚的に把握できます。 形状が“わかりやすい”ことが利点ですよね。 SOLIDWORKSでは3Dモデルを作成します。 わかりやすいモデルは 相手にイメージを伝えやすくなります。 活用しない手はないということで、   今回は、 3D CADは持っていないけれど データは見たい!! 普段3D CADを扱わない人に 簡単にデータを見てもらいたい!! そんなときに活躍する方法をご紹介します。   3D CADのデータを3D PDFに書き出す   今回は、こちらのアセンブリモデルを 3D PDFとして保存します。     <メニューバー>「保存」のプルダウンメニューから 「指定保存」をクリックします。   設定を次の通りに行い、保存をクリックします。 ファイルの種類:Adobe Portable Document Format (.pdf) 3D PDF保存:チェックを入れる 3D PDFを作成することができました。     作成した3D PDFは、 Adobe Acrobat Readerなどの ソフトがインストールされていれば、 ファイルを開いて閲覧することができます。 3Dデータは、マウスを使ってモデルを 拡大縮小、回転、平行移動などを行えます。     その他にも、部品を透明することもできます。 ホルダー部品のみを透明にしてみましょう。 まず、モデルツリーを確認します。 「モデルツリーの切り替え」をクリックします。 モデルツリーが展開されました。 ホルダーを右クリックし、「透明」を選択します。   ホルダー部品を透明にすることができました。 この他にも 簡易的な距離計測やパース表示にするなど できることは多いです。 お手軽で良い方法だと思いますので、 試してみてください。    ...

詳細穴コマンド

穴ウィザードコマンドは、 ねじ穴を作成するコマンドですね。   今まで、穴ウィザードでは 「ザグリ穴+下穴」の組み合わせを 一度に行うことができませんでした。 しかし、それを可能にしたのが SOLIDWORKS2018からの新機能、 「詳細穴」コマンドです。   このコマンドでは、表側からの穴仕様と、 そのさらに下の穴仕様、そして、 裏側からの穴仕様を個別に設定できます。 加工段階のある穴を作成することができます。   ●実際に使用してみましょう。 1. フィーチャータブ「穴ウィザード」コマンドの フライアウトボタン▼をクリックして、 「詳細穴」コマンドをクリック。 2. PropertyManager が開き、 「表側」フライアウトが表示されます。 ●表面要素のザグリ穴を設定します。 3. 最初に、穴のタイプを選択します。 プルダウンをクリックし、「表側座グリ」をクリック。 4. 穴を開ける面を選択します。 5. 次に、ザグリ穴の要素仕様を設定します。 ザグリ穴の仕様が設定できました。   ●次に、2番目の表面要素の穴の仕様を決めます。 6. 「表側」フライアウトから 「アクティブ要素の下に要素を挿入」をクリック。 7. プルダウンをクリックし、 「ねじ穴-ストレート」をクリック。 8. 穴の要素仕様を設定します。 2番目の表側要素の穴の仕様が設定できました。 ●穴位置を決めます。 9. 「位置」タブに切り替えます。 10. スケッチタブ「点」コマンドが 選択状態になっていることを確認します。 (選択状態になっていなかったら選択します。) 11. 穴を開けたい位置でクリックします。 (寸法を入れて位置を決めることもできます。) 12. OKをクリック。 13. 表側がザグリ穴、その下の穴が タップ穴の加工が出来ました。 今回は、 表側から「ザグリ穴+タップ穴」を設定しましたが 色々な穴の加工方法が選択でき、 裏側からも設定ができます。 ぜひお試し下さい。...

【モデルテクニック】任意の断面の表示状態を保存する

  前回は「断面表示」についてご紹介しました。 ↓ ↓ ↓ モデルの断面表示   今回は、断面表示の応用となる機能をご紹介します。 機能は 「断面表示の保存」 です。 上の図のように、自分で作成した断面を いつでも表示できるようになったら便利ですよね!   まずは、任意の断面表示を作成してみましょう。   <ヘッズアップビューツールバー>から 「断面表示」をクリック   今回の設定は、 正面を選択して、角度を60°   「断面2」にチェックを入れ、 平面を選択して、距離を80mmです。   画面上はこのようなプレビューになっています。   この表示状態を保存します。 スクロールバーを動かして、 プロパティの一番下にある「保存」をクリック。     「指定保存」のダイアログボックスが現れます。 表示方向名に「テスト断面」と入力し、 「保存」をクリックします。 これで断面表示の 状態が保存できました。   それでは確認していきましょう。 メニューバーから 「表示」→「表示コントロール」→「表示方向」 を選択します。   「表示方向」のダイアログボックスが現れます。 「テスト断面」が保存されていることが確認できます。   モデルの表示方向を、正面、等角投影などにしていても、 この「テスト断面1」を選択すると、 保存された断面の表示状態になります。   ぜひお試し下さい。...

【モデルテクニック】モデルの断面表示

  今回はモデルの表示方法のひとつ、 「断面表示」 をご紹介します。   円筒のモデルがあります。 外見では、このモデルの中側がどうなっているのかわかりませんよね。   断面表示は、モデルの内側形状の確認や、 内側の要素を選択したいときなどに有効です。   それでは、断面表示を使用してみましょう。   <ヘッズアップビューツールバー>から 「断面表示」をクリック。 ※メニューバー「表示」→「表示タイプ」→「断面表示」 から選択することもできます。   プロパティに切り替わり、プレビューが表示されます。     OKをクリックすると、断面が表示されて内側が確認できます。   断面が表示されている間は、「断面表示」アイコンがONになっています。     クリックすると解除できます。     断面の方向を追加することもできます。     また、SOLIDWORKS 2017からは 断面表示にした際の非表示部分の透明度を指定できるようになりました。   OKをクリックすると、   マルチボディの場合は、透明化を除外するボディも指定できます。 色々とお試しいただけると幸いです。...

ビューの必要な部分のみ表示する方法「ビューのトリミング」

これは駆動軸です。 みなさんは、SOLIDWORKSでこの駆動軸の図面を作成する場合、 投影図はどのように表現していますか。 一つの方法として、 下図のように正面図と平面図のビューを作成する方法が考えられます。 しかし、駆動軸の平面図は、 キー溝部分のみ図示すれば、 全体の図を描かなくても形状がわかりますね。 今回は、キー溝部分を 局部投影図で表す場合などに 使用できるコマンドをご紹介します。 コマンドは、 「ビューのトリミング」です。 ビューのトリミングを使用する場合は、 閉じたスケッチを書いておく必要があります。   1. ビュー内の残したい部分を囲むようにスケッチを描きます。 ここでの注意点は、残したい部分のビューがアクティブな状態で スケッチ描くということです。 下図ように“ビューをアクティブ維持の状態(四角が実線のピンクの点線)”にして、 点線の内側に閉じたスケッチを描きます。     2. 1で作成したスケッチ線を全て選択した状態で、 <レイアウト表示タブ>から「ビューのトリミング」をクリックします。     3. 図面ビューのトリミングが行われ、選択した領域のみ表示できます。     4. このときに、トリミングの輪郭線をなくしたり、 ギザギザの輪郭線にすることもできます。    これは、ビューを選択しておいてから、 プロパティの“ビューのトリミング”のチェックボックスで行います。     5. 更に、トリミング後も残った不要な線を非表示にするには、 線を選択して、「エッジ非表示/表示」をクリックします。     6. 不要な線が非表示にでき、 局部投影図で表すことができました。       JIS製図に合わせるとしたら、 主となる投影図と局部投影図を細い実線で結んでおきます。   また、一度トリムしたものを、やり直したり、削除するには、 ① トリムしたビューを右クリック。 ショートカットメニューから、「ビューのトリミング」→「トリミングを編集」をクリック。 ※削除する場合は「トリミングを削除」をクリック。     ② スケッチ編集の状態になり、 矩形の大きさや位置などを調整することができます。     ぜひお試しください。...

図面ビューの境界線

図面ドキュメントで図面ビューにポインタを近づけると、 図面ビューの境界がハイライトします。 今回は、この図面ビューの境界線の状態をご紹介します。     境界線の色は選択状態を表しますが 概ね他のドキュメント(部品・アセンブリ)と同様です。 しかし、以外と知らない方も多い 図面ドキュメントならではの選択状態が登場します。   それでは確認していきましょう。       「選択前」 ビューにポインタを近づけると、オレンジ色の破線が表れます。 これは、ダイナミックハイライト「選択前」を示します。   「選択前」なので、実際に選択はしていません。 ポインタをはずすと破線が消えます。         「選択状態(アクティブ)」 ビューにポインタを近づけてクリックすると、水色の破線が表れます。 これは、「選択状態」を示します。   選択しているので、ポインタをはずすしても継続します。       「アクティブ維持」 ビューをダブルクリックすると、水色の破線の四角が太い実線になります。 この状態が、「ビューアクティブ維持」を示します。 また、続けて何もないところをクリックすると、 ピンク色の破線に変わります。 これは、選択状態は解除されましたが、 「ビューアクティブ維持」が継続していることを示します。 図面に注記やスケッチなどの要素を挿入する際に 重要です。     みなさんは、図面に注記やスケッチを挿入する際に、 予期せぬ位置に挿入されてしまったことはありませんか?   例えば、アクティブ維持ではない状態で、 矩形のスケッチを追加した場合 ビューをドラッグすると・・・スケッチが追従しません。 これは、挿入する要素がどのビューに関連するものなのか 明らかではないからです。 一方、ビューを「アクティブ維持」にして、 矩形のスケッチを追加した場合、 ビューをドラッグすると・・・スケッチがビューに追従します。 このように「アクティブ維持」にして 関連付けを明確にしてから要素を追加すると、 そのビューの一部として扱われます。   そのため、ビューを移動した際には、 そのビューに追従して動くのです。 せっかく描いたスケッチが追従しなかったら ちょっと残念に感じますよね。   スマート寸法コマンドなどの使用では、 挿入したいビューにポインタを近づけると、 自動的にアクティブ維持になります。 ですから、意識をしていなくても作業ができます。   しかし、自動的にアクティブにならないような スケッチコマンドなどの使用の際には、 「アクティブ維持」を意識しましょう。...

丸みのあるコーナー部に仮想交点を表示するには

2D図面作図の際、「丸みのあるコーナー」に寸法を入れるには、 仮想交点が必要になります。 もし、あなたがスケッチの直線で仮想交点を作図しているのなら、 今回の記事が有益です。 スケッチの直線を作図して仮想交点を作るよりも 手軽な方法をご紹介します。     「仮想交点」の作成方法 1. 仮想交点が必要な2本の直線をCtrlキーを押しながら、 順番にクリックして選択します。 2. そして、スケッチツールの「点」をクリックします。 3. 選んだ2本の直線の仮想交点が作成されます。 4. 残りの仮想交点も作成します。 5. 寸法入力は、この仮想交点をクリックします。 いかがでしたか? 仮想交点が簡単に作成できたと思います。 ぜひ、ご活用ください。  ...