アセンブリ

連続するエッジを簡単に選択する

複雑な形状の輪郭を参照する際に “ここからここまでのエッジを選択したいのにうまく選択できない” ということがあります。 連続する接続エッジを選択する場合、 細かいエッジがたくさん含まれていると選択しにくいですよね。 今回は、 指定エッジから指定エッジまでの 「連続したエッジを簡単に選択する方法」 をご紹介いたします。   「部分ループ選択」 「部分ループ選択」とは、指定エッジから指定エッジまでの連続したエッジを 簡単に選択することができる機能です。 例えば下図のように、連続したエッジを選択したいときに使うと便利です。 今回は時計回りにエッジを選択してみます。 手順 (1) 選択の開始となるエッジをクリックします。 (2) 「Ctrl」キーを押しながら選択の終了となるエッジを「右クリック」します。 (3) メニューから「部分ループ選択」をクリックします。 (4) 部分的に連続したエッジを選択することができました。 注意点 手順(2)では、中点より始点に近い側を右クリックすること。 上図のように中点より終点に近い側(赤い矢印のあたり)を右クリックした場合は、始点から反時計回りに連続したエッジが選択されます。 ※ ソリッドボディのエッジを選択する場合は、選択エッジが同じ面上にある必要があります。   まとめ いかがでしたでしょうか? 今回ご紹介した「部分ループ選択」は、細かいエッジが含まれていればいるほど効果を発揮します。 操作方法はとても簡単ですが、かなりの時間が短縮できますね。   補足「ループ選択」 接続エッジの外周を一度に選択する方法には 「ループ選択」があります。 こちらもあわせてご確認ください。 https://cadrise.jp/manual/so_manual/loop/ ...

「ねじ」の長さを追加する方法 – Toolbox

製品を設計する際には、 自分でモデリングを行う部品だけでなく 標準部品も使用しますよね。 そこでアセンブリ作成の効率を上げるために 使用する標準部品の追加機能が「Toolbox」です。 SOLIDWORKSのアドイン機能として 搭載されている「Toolbox」には、 さまざまな工業規格に対応した標準部品が用意されています。 それらの部品は、アセンブリドキュメントの画面上に ドラッグ&ドロップするだけで簡単に追加できます。 ※Toolboxが搭載されていないパッケージもあります。 Toolboxの使用方法はこちらから https://cadrise.jp/manual/so_manual/toolbox_bolts/ そんな素敵な機能ですが、 皆さんはToolboxを使用して ボルトを挿入しようとした際に、 “挿入したいボルトの長さがなかった” という経験はありませんか。 今回はToolboxに用意された既存のデータを編集し カスタマイズをする方法をご紹介いたします。 「Toolboxコンフィギュレーション設定」   まず、「デザインライブラリ」をクリックします。 (SOLIDWORKSを開くと画面右側にタスクパネルがあります。 上から2つ目が「デザインライブラリ」です。) 次に、「Toolboxコンフィギュレーション設計」をクリックします。   Toolboxの設定ダイアログボックスが開きます。   「ハードウェアのカスタマイズ」をクリック。   Toolboxの規格に「JIS」をクリックして選択します。   カテゴリから「ボルトとネジ」をクリック。   タイプに「六角ボルト」をクリック。   「全ねじ六角ボルト(部品等級A)」を選択します。   今回はボルトの首下の長さ変更したいので、 標準プロパティから「Length」をクリック。   「新規サイズを追加」をクリック。   「新規サイズ追加」ダイアログボックスが開きます 追加したいサイズと長さを入力し「OK」をクリック。   スクロールバーを移動すると1番下に 新しいサイズが追加されています。   いかがでしたでしょうか。 カスタマイズを行うと更に使い勝手が良くなりますね。 ぜひ、お試しください。...

部品の動きを確認しよう ~制限合致②~

  前回に引き続き、【制限合致】のご紹介です。 第1弾はこちらから ↓ ↓ ↓ 部品の動きを確認しよう ~制限合致①~ https://cadrise.jp/qanda/limit-mates/   第2弾の今回は、 [サブアセンブリのフレキシブル化]です。 下図の前回のアセンブリを 最終組立となるアセンブリに挿入して 動きを確認します。 コンフィギュレーションとは違い 可動範囲もリアルにわかるのでとても便利です。       [サブアセンブリのフレキシブル化]   まず、2種類のアセンブリを用意します。 ①トップアセンブリ (装置全体の最終組立品のこと) ②サブアセンブリ (トップアセンブリを構成する組立品のこと) ※今回の②は前回で【制限合致】をつけたアセンブリを指します。   実際にサブアセンブリを挿入したトップアセンブリ   ところが・・・   サブアセンブリ作成時は 制限距離の範囲で動いたテーブルが、 トップアセンブリに挿入すると動きません。 これはサブアセンブリが“リジット”という 固定された状態だからです。   そこで、サブアセンブリを“フレキシブル”という 固定されていない状態にする必要があります。 ※SOLIDWORKSのデフォルト設定では、 トップアセンブリの中でサブアセンブリは 一つのユニットとして動作するため 固定される仕様です。   ツリーからサブアセンブリを右クリック。 コンテキストツールバーから 「サブアセンブリをリジットに指定」をクリックします。   すると・・・ サブアセンブリがフレキシブルになります。   ツリーをよく見るとフレキシブルに設定したアセンブリは、 アイコンが変わっています。 どのサブアセンブリがフレキシブルで 可動するのかすぐにわかりますね。     フレキシブルにしたことで、 サブアセンブリのテーブルは 制限合致で定義した可動域の範囲で移動します。     より具体的に動きを再現することができますね。 ぜひお試しください。    ...

部品の動きを確認しよう ~制限合致①~

  装置設計で機械の動きを表現する場合、 コンフィギュレーションを用いることがあります。 コンフィギュレーション機能は、 1 つのドキュメント内に 形状違いなど複数の部品やアセンブリモデルを作成できます。   例えばシリンダなどの装置設計で動きをみる際に コンフィギュレーションを用いた場合は 「最大」や「最小」といった特定の位置の状態を再現できます。 コンフィギュレーションの追加はこちらから https://cadrise.jp/manual/so_manual/%e3%82%b3%e3%83%b3%e3%83%95%e3%82%a3%e3%82%ae%e3%83%a5%e3%83%ac%e3%83%bc%e3%82%b7%e3%83%a7%e3%83%b3%e3%81%ae%e8%bf%bd%e5%8a%a0/     設計をするときに、 「実際の動きを確認しながら設計をしたい」 と思ったことありませんか? 今回ご紹介するコマンドを使用することで、 部品がどのように動くのかを表現することができます。 2回に渡ってご紹介する内容はこちら☟ 第1弾 【制限合致】 第2弾 【サブアセンブリのフレキシブル化】     今回は、設定をするにあたっての準備段階 【制限合致】 です。   まず、動きを持たせたいアセンブリを用意します。 今回は、テーブルが下記の設定で移動します。 ・テーブルの中心と下部品の端の移動量250mm 最小値:70mm(下部品端から) 最大値:320mm(下部品端から)   移動前(最小値)   移動後(最大値)       それでは、距離を制限した合致をつけましょう。 アセンブリタブ→「合致」コマンドをクリック。 合致設定に、図の2つ面を選択します。 「詳細設定合致」を展開し、「制限合致」をクリック。 距離に最小値:70mm(下部品端から)が選択されます。 最大値と最小値を設定します。 最大値:320mm(下部品端から) 最小値:70mm(下部品端から)   合致コマンドを終了します。 移動距離を制限した合致をつけることができました。   距離制限をつけたことにより テーブル可動域の範囲で移動します。     次回は、このアセンブリ部品を 実際の装置(トップアセンブリ)に挿入して動かします。 【サブアセンブリのフレキシブル化】 ご期待ください。...

3D CADデータを活用しよう ~3DPDF~

  3Dモデルは、製品の形状や構造を 視覚的に把握できます。 形状が“わかりやすい”ことが利点ですよね。 SOLIDWORKSでは3Dモデルを作成します。 わかりやすいモデルは 相手にイメージを伝えやすくなります。 活用しない手はないということで、   今回は、 3D CADは持っていないけれど データは見たい!! 普段3D CADを扱わない人に 簡単にデータを見てもらいたい!! そんなときに活躍する方法をご紹介します。   3D CADのデータを3D PDFに書き出す   今回は、こちらのアセンブリモデルを 3D PDFとして保存します。     <メニューバー>「保存」のプルダウンメニューから 「指定保存」をクリックします。   設定を次の通りに行い、保存をクリックします。 ファイルの種類:Adobe Portable Document Format (.pdf) 3D PDF保存:チェックを入れる 3D PDFを作成することができました。     作成した3D PDFは、 Adobe Acrobat Readerなどの ソフトがインストールされていれば、 ファイルを開いて閲覧することができます。 3Dデータは、マウスを使ってモデルを 拡大縮小、回転、平行移動などを行えます。     その他にも、部品を透明することもできます。 ホルダー部品のみを透明にしてみましょう。 まず、モデルツリーを確認します。 「モデルツリーの切り替え」をクリックします。 モデルツリーが展開されました。 ホルダーを右クリックし、「透明」を選択します。   ホルダー部品を透明にすることができました。 この他にも 簡易的な距離計測やパース表示にするなど できることは多いです。 お手軽で良い方法だと思いますので、 試してみてください。    ...

【モデルテクニック】任意の断面の表示状態を保存する

  前回は「断面表示」についてご紹介しました。 ↓ ↓ ↓ モデルの断面表示   今回は、断面表示の応用となる機能をご紹介します。 機能は 「断面表示の保存」 です。 上の図のように、自分で作成した断面を いつでも表示できるようになったら便利ですよね!   まずは、任意の断面表示を作成してみましょう。   <ヘッズアップビューツールバー>から 「断面表示」をクリック   今回の設定は、 正面を選択して、角度を60°   「断面2」にチェックを入れ、 平面を選択して、距離を80mmです。   画面上はこのようなプレビューになっています。   この表示状態を保存します。 スクロールバーを動かして、 プロパティの一番下にある「保存」をクリック。     「指定保存」のダイアログボックスが現れます。 表示方向名に「テスト断面」と入力し、 「保存」をクリックします。 これで断面表示の 状態が保存できました。   それでは確認していきましょう。 メニューバーから 「表示」→「表示コントロール」→「表示方向」 を選択します。   「表示方向」のダイアログボックスが現れます。 「テスト断面」が保存されていることが確認できます。   モデルの表示方向を、正面、等角投影などにしていても、 この「テスト断面1」を選択すると、 保存された断面の表示状態になります。   ぜひお試し下さい。...

【モデルテクニック】モデルの断面表示

  今回はモデルの表示方法のひとつ、 「断面表示」 をご紹介します。   円筒のモデルがあります。 外見では、このモデルの中側がどうなっているのかわかりませんよね。   断面表示は、モデルの内側形状の確認や、 内側の要素を選択したいときなどに有効です。   それでは、断面表示を使用してみましょう。   <ヘッズアップビューツールバー>から 「断面表示」をクリック。 ※メニューバー「表示」→「表示タイプ」→「断面表示」 から選択することもできます。   プロパティに切り替わり、プレビューが表示されます。     OKをクリックすると、断面が表示されて内側が確認できます。   断面が表示されている間は、「断面表示」アイコンがONになっています。     クリックすると解除できます。     断面の方向を追加することもできます。     また、SOLIDWORKS 2017からは 断面表示にした際の非表示部分の透明度を指定できるようになりました。   OKをクリックすると、   マルチボディの場合は、透明化を除外するボディも指定できます。 色々とお試しいただけると幸いです。...

アセンブリ上で部品の形状を簡単に確認する方法

みなさんは、アセンブリドキュメントで挿入している 部品の形状を確認する際、どのようにされていますか? ほとんどの方が「部品を開く」コマンドで 部品を開いて確認していると思います。   しかし、この方法は 多くのドキュメントを開いている場合や、 保存の際に警告メッセージが出てきたりと 若干煩わしく感じませんか。 今回ご紹介するコマンドでは、 アセンブリ画面上で部品の形状を確認できる ため 煩わしい手間を省くことができます。   そのコマンドは 「構成部品プレビューウィンド」 まず、確認したい部品を右クリックします。 表示されたコンテキストツールバーより、 「構成部品プレビューウィンド」をクリック。 部品のプレビューが表示されました。 プレビュー表示をした部品を回転してみましょう。 プレビューウィンドを閉じるには、「プレビュー終了」ボタンをクリックします。   いかがでしたか。 形状の確認が容易にできますよね。 ただし、今回のプレビューウィンド実行中は、 部品の編集や測定などのコマンドは使用できません。 そのようなコマンドを使用したい場合は、 「部品を開く」コマンドで部品を開いて行ってください。 ぜひお試しください。...

よく使う部品を簡単に呼び出す【デザインライブラリ】

よく使う購入部品や標準部品をアセンブリドキュメント内に配置する際、 どのように部品データを読み込んでいますか?       SOLIDWORKSの「既存の部品/アセンブリ」コマンドから、 あるいはエクスプローラーからドラッグ&ドロップで読み込む方が 多いのではないでしょうか。   しかしこれらの方法では、 ファイルを読み込もうとする度に その部品の保存先のフォルダを 探しに行かなければなりません。   今回は、こういったときに簡単に部品を読み込める オススメの方法をご紹介します。       それは、 「デザインライブラリ」です。 【デザインライブラリとは?】 使用頻度の高い部品・アセンブリなどのデータを、 登録しておくことができる場所です。 簡単にドキュメントへ追加することができます。     まずは、よく使う部品の保存先のフォルダを登録します。 SOLIDWORKSを開くと画面右側にタスクパネルがあります。 上から2つ目の「デザインライブラリ」をクリック。 「ファイルの場所を追加」をクリックし部品の保存先フォルダを指定します。 (ここでは、「標準部品」というフォルダを指定しました)   すると、右側の「デザインライブラリ」に指定したフォルダが追加されます。 (「標準部品」という先ほど指定したフォルダが加わっていますね) こちらをクリックすると、フォルダ内に保存されている部品などが デザインライブラリ下部に表示されます。   あとは実際にこれらの部品を配置したいアセンブリドキュメントを開き、 配置したい部品をアセンブリドキュメントへ ドラッグ&ドロップすれば簡単に配置できます。   以降、この部品を配置する際は 「デザインライブラリ」から簡単にアセンブリへ 読み込むことができます。         いかがですか? お仕事によっては何度も使う部品が沢山ある方も いるかと思います。 決まったアイテムは、探しに行かなくてもすぐにドロップできたら 作業効率も大幅に上がりますね。     ******** その他、活用方法もご紹介します。 「デザインライブラリ」から スケッチをブロックにして登録したり、 注記(テキスト)を登録し読み込むこともできます。   また、グループの共有ディレクトリにフォルダ作成し、 そのフォルダをデザインライブラリに登録することで、 データを共有して使用できます。 色々な活用方法がありますので まだ使ったことがない方は是非試してみてくださいね。  ...

ツールボックスの編集

今回はツールボックスの編集方法を お伝えします! (前回紹介したツールボックスの使い方はコチラ) 頂いたご質問↓ =============== toolbox/コンフィギレーション/ユーザ設定の定義/設定/ ファイルの コンフィギレーションの作成と部品作成の区別が今一つ はっきりしません。 (1)toolboxの部品を加工したり、編集する時に、マスターファイルを 上書きしない場合には、 部品作成を指定し、データを保存するフォルダ を作成(指定)すればいいと理解していいでしょうか。 (2)また、sw2007で作成したデータをsw2007というフォルダに元のデータ と編集したデータを保存。 sw2013で呼び出すとすると、2013側のtoolbox側で部品作成として のフォルダをsw2007 に指定する必要がありますか? この場合、①を作成せず、sw2007とかsw2013のフォルダに元のデータと 加工したデータを保存する方法では不都合がありますか? (3)システムオプションに穴ウイザード/toolboxがありますが、 ここでのフォルダ  C:\SolidWorks Data\ と  検索boxに チェックを入れるか いれないかの区別が初心者のため理解できません。 =============== (1)ツールボックスの部品の加工、編集方法 まずは編集画面へ。 ツール→Toolbox→コンフィギュレーション 新たなウィンドウが開きますので2.ハードウェアのカスタマイズをクリック。 ここで編集が出来るようになります。 まずは部品の保管先フォルダを作成します。 (※テストというフォルダを作成しました) 元データから編集する場合、元となるデータをコピーして、 作成したフォルダにペーストします。 ⇒ これをクリックすると編集画面になります。 「有効」のチェックはこの部品を使えるようにするかどうか、 「ユーザー定義コンフィギュレーション名を許可」では画像下のコンフィギュレーション名を変更できます。 その他説明やファイル名を変更でき、 「標準プロパティ」ではサイズ、長さなど様々なものを変更できます。 元データを使って編集したい場合はコチラを編集してください。 最後に左上にある保存ボタンで保存します。 部品ファイルで部品を作成した場合は フォルダを右クリックして出てきた「ファイルの追加」で使用できるようになります。 (2)バージョンの違いについて SOLIDWORKSのツールボックスは基本的に バージョンに依存しています。 SOLIDWORKS2016は2016のツールボックス、 2014は2014のツールボックスと、それぞれ参照します。 ですから、バージョンが違うと参照がうまくいかない場合も発生します。 過去バージョンを開いた時、保存について基本的には元データのところに 追加保存もできます。しかし、新規追加する場合は「フォルダの作成」をオススメします。 あとで見たときに分かりにくくなる管理の不便さが発生するからです。 または、ツリーで部品を右クリックし、出てきたメニューから 「構成部品置き換え」にて 現バージョンに修正するなども可能です。 (3)ツールボックスの呼び出しについて バージョンに依存せず、一つのツールボックスだけを参照する 方法もあります。 設定から ツールボックスの画面で出てくる指定フォルダを 変更し、チェックボックスにチェックをいれます。 この設定をしておくと、アセンブリ上で本のマークをクリックすると、 ここで指定したフォルダが開くことになります。 私はSOLIDWORKS2016を使用していたので、デフォルトでは2016が指定されています。 しかし、2015のデータを使いたい、社内のツールボックスを使いたい場合などがあれば そのフォルダを指定して、指定のチェックを入れておきます。 いかがでしたか? 今回の内容はかなりレベルが高いかもしれません^^; 普段使わない方も、ツールボックスを使わなきゃ!という時に 思い出してもらえたら幸いです。...