モデル作成

簡単にねじ山のモデリングをする方法

ねじ山をリアルに見せたい時に どうやって3Dモデルで作成しようかと 悩んだことはありませんか。 作成するにしても ヘリカルとスパイラルコマンドで 螺旋を描きねじの谷スケッチを書き・・・ と大変だったかと思います。 そんな3Dモデルで ねじ山をリアルに作成するときに 便利なコマンドをご紹介いたします。 「ねじ山」 円筒形状に対してねじ山をモデリングできます。 (これはSOLIDWORKS2016からの機能です。)     メニューバー/挿入から、 「フィーチャー」→「ねじ山」をクリックします。     コマンドを実行すると 下図のようなアラートメッセージ現れます。 ※これは実際に加工する寸法が適用されたスケッチ輪郭ではないので、 3Dデータからの生産には用いないようにとのメッセージです。 OKをクリックします。   ねじ山コマンドが実行され、PropertyManagerが開きました。   今回は全ねじボルトを作成してみたいと思います。 まず、ねじ山を作成したいエッジを選択します。     選択するとプレビューが表示されます。     この時に、オフセットにチェックを入れ 距離を設定すると(場合によっては反対方向にチェック) モデル端までねじ山を作成することができます。     次に、押し出し状態を設定します。 今回は「次の選択まで」を選択し、六角ボルトの裏面を選択します。     選択するとプレビューが表示されます。   次にネジの仕様を設定します。 種類:「Metrir Die」 サイズ:「M4x0.7」 ねじ山の作成方法:「ねじ切り」にチェックを入れる   スクロールバーを下に移動して ねじ山のオプションを設定します。 「右ねじ」と「端面でトリム」にチェックを入れる       OKボタンをクリックすると、 ねじ山を作成することができました。   いかがでしたでしょうか。 簡単にねじ山を作成することができますね。     上記の方法でねじ山を作成したモデルを図面化すると、 作成された形状の通りに投影されるので実形図示になります。     図面でねじを通常図示したい場合は、 メニューバー/挿入から、 「アノテートアイテム」→「ねじ山」を使用してください。     こちらはネジ部を作成する方法でご紹介をしています。 https://cadrise.jp/manual/screwcreated/ あわせてご覧いただければ幸いです。    ...

3D CADデータを活用しよう ~3DPDF~

  3Dモデルは、製品の形状や構造を 視覚的に把握できます。 形状が“わかりやすい”ことが利点ですよね。 SOLIDWORKSでは3Dモデルを作成します。 わかりやすいモデルは 相手にイメージを伝えやすくなります。 活用しない手はないということで、   今回は、 3D CADは持っていないけれど データは見たい!! 普段3D CADを扱わない人に 簡単にデータを見てもらいたい!! そんなときに活躍する方法をご紹介します。   3D CADのデータを3D PDFに書き出す   今回は、こちらのアセンブリモデルを 3D PDFとして保存します。     <メニューバー>「保存」のプルダウンメニューから 「指定保存」をクリックします。   設定を次の通りに行い、保存をクリックします。 ファイルの種類:Adobe Portable Document Format (.pdf) 3D PDF保存:チェックを入れる 3D PDFを作成することができました。     作成した3D PDFは、 Adobe Acrobat Readerなどの ソフトがインストールされていれば、 ファイルを開いて閲覧することができます。 3Dデータは、マウスを使ってモデルを 拡大縮小、回転、平行移動などを行えます。     その他にも、部品を透明することもできます。 ホルダー部品のみを透明にしてみましょう。 まず、モデルツリーを確認します。 「モデルツリーの切り替え」をクリックします。 モデルツリーが展開されました。 ホルダーを右クリックし、「透明」を選択します。   ホルダー部品を透明にすることができました。 この他にも 簡易的な距離計測やパース表示にするなど できることは多いです。 お手軽で良い方法だと思いますので、 試してみてください。    ...

詳細穴コマンド

穴ウィザードコマンドは、 ねじ穴を作成するコマンドですね。   今まで、穴ウィザードでは 「ザグリ穴+下穴」の組み合わせを 一度に行うことができませんでした。 しかし、それを可能にしたのが SOLIDWORKS2018からの新機能、 「詳細穴」コマンドです。   このコマンドでは、表側からの穴仕様と、 そのさらに下の穴仕様、そして、 裏側からの穴仕様を個別に設定できます。 加工段階のある穴を作成することができます。   ●実際に使用してみましょう。 1. フィーチャータブ「穴ウィザード」コマンドの フライアウトボタン▼をクリックして、 「詳細穴」コマンドをクリック。 2. PropertyManager が開き、 「表側」フライアウトが表示されます。 ●表面要素のザグリ穴を設定します。 3. 最初に、穴のタイプを選択します。 プルダウンをクリックし、「表側座グリ」をクリック。 4. 穴を開ける面を選択します。 5. 次に、ザグリ穴の要素仕様を設定します。 ザグリ穴の仕様が設定できました。   ●次に、2番目の表面要素の穴の仕様を決めます。 6. 「表側」フライアウトから 「アクティブ要素の下に要素を挿入」をクリック。 7. プルダウンをクリックし、 「ねじ穴-ストレート」をクリック。 8. 穴の要素仕様を設定します。 2番目の表側要素の穴の仕様が設定できました。 ●穴位置を決めます。 9. 「位置」タブに切り替えます。 10. スケッチタブ「点」コマンドが 選択状態になっていることを確認します。 (選択状態になっていなかったら選択します。) 11. 穴を開けたい位置でクリックします。 (寸法を入れて位置を決めることもできます。) 12. OKをクリック。 13. 表側がザグリ穴、その下の穴が タップ穴の加工が出来ました。 今回は、 表側から「ザグリ穴+タップ穴」を設定しましたが 色々な穴の加工方法が選択でき、 裏側からも設定ができます。 ぜひお試し下さい。...

【モデルテクニック】任意の断面の表示状態を保存する

  前回は「断面表示」についてご紹介しました。 ↓ ↓ ↓ モデルの断面表示   今回は、断面表示の応用となる機能をご紹介します。 機能は 「断面表示の保存」 です。 上の図のように、自分で作成した断面を いつでも表示できるようになったら便利ですよね!   まずは、任意の断面表示を作成してみましょう。   <ヘッズアップビューツールバー>から 「断面表示」をクリック   今回の設定は、 正面を選択して、角度を60°   「断面2」にチェックを入れ、 平面を選択して、距離を80mmです。   画面上はこのようなプレビューになっています。   この表示状態を保存します。 スクロールバーを動かして、 プロパティの一番下にある「保存」をクリック。     「指定保存」のダイアログボックスが現れます。 表示方向名に「テスト断面」と入力し、 「保存」をクリックします。 これで断面表示の 状態が保存できました。   それでは確認していきましょう。 メニューバーから 「表示」→「表示コントロール」→「表示方向」 を選択します。   「表示方向」のダイアログボックスが現れます。 「テスト断面」が保存されていることが確認できます。   モデルの表示方向を、正面、等角投影などにしていても、 この「テスト断面1」を選択すると、 保存された断面の表示状態になります。   ぜひお試し下さい。...

【モデルテクニック】モデルの断面表示

  今回はモデルの表示方法のひとつ、 「断面表示」 をご紹介します。   円筒のモデルがあります。 外見では、このモデルの中側がどうなっているのかわかりませんよね。   断面表示は、モデルの内側形状の確認や、 内側の要素を選択したいときなどに有効です。   それでは、断面表示を使用してみましょう。   <ヘッズアップビューツールバー>から 「断面表示」をクリック。 ※メニューバー「表示」→「表示タイプ」→「断面表示」 から選択することもできます。   プロパティに切り替わり、プレビューが表示されます。     OKをクリックすると、断面が表示されて内側が確認できます。   断面が表示されている間は、「断面表示」アイコンがONになっています。     クリックすると解除できます。     断面の方向を追加することもできます。     また、SOLIDWORKS 2017からは 断面表示にした際の非表示部分の透明度を指定できるようになりました。   OKをクリックすると、   マルチボディの場合は、透明化を除外するボディも指定できます。 色々とお試しいただけると幸いです。...

スマート寸法ポインタの種類

    スケッチで寸法を入れる時に、 このようなポインタになって困ったことはありませんか? 実は、このポインタの時には 十字矢印を基準に角度寸法を入れる状態になっています。 今回は、このポインタが表示される原因と使い方、解除方法をみていきます。   **** 【解除方法は?】 スマート寸法を使用していて、十字矢印が現れたときには Escキーを押すと解除できます。   しかし、よく見てみると、点がまだ選択されています。 点に関連しない箇所へ寸法を入れたい場合は、 もう一度Escキーを押します。 すると、点の選択が解除され、 スマート寸法が使用できる状態に戻ります。   【このポインタ、どんな時に出てくるの?】 スマート寸法コマンドに入り、点をクリックします。 その後、点に接続している線をクリックすると現れます。 また、スケッチを描いて寸法を入れる動作の中で、 いつの間にかこの十字矢印が現れている時があります。 これは、作図の最後に点が選択された状態からスマート寸法コマンドを開始し、 線を選択している場合が多いです。   【どうやって使用するの?】 十字矢印を仮想の線として認識し、角度寸法を入れることができます。 (上の動作からの続きとなります) 十字矢印の一つの矢印を選択します。 選択した矢印を仮想の線として認識し、角度寸法が現れます。 クリックして角度寸法を配置します。 いかがでしたか? スマート寸法コマンドで現れる、 十字矢印のポインタが、どうして現れていたのか 原因がわかればスッキリしますよね。 解除するにはEscキーです!  ...

ネジ部を作成する方法

  前回ご紹介したネジをネジらしく見せる方法。 https://cadrise.jp/manual/indicatethread/ こちらで紹介したのは、見た目を「ねじらしく見せる」設定でした。   しかし、そもそもこのモデルにねじの設定をしていなければ、 表示できないのはもちろん、図面でもただのねじっぽい円柱になってしまいます。   そこで、今回はねじ部の作成方法をご紹介します。 この操作を行うと、しっかりねじ部が表示されます。 ※ねじ穴は「穴ウィザード」コマンドで作成できます。   ではねじ部の作成方法を見ていきましょう。 メニューバーの「挿入」から「アノテートアイテム」を選択し、 アノテートアイテム内の「ねじ山」をクリックします。   プロパティが開くので、ねじの設定をしていきます。   「円形エッジ」の選択エリアに、 ねじの開始点となるエッジをクリックします。 エッジを選択した後に、規格を選択します。 ここでは「JIS」を選択します。   次に、ねじサイズの設定を行います。 このモデルは、円筒の直径が10mmなので M10x1.5(並目)を選択しています。 ねじのサイズによって細目もあるので、 必要に応じて設定してください。   ねじサイズを設定したら、ねじの長さを設定します。 このモデルでは、端から25mmの長さに設定しています。 OKをクリックするとモデルにネジ部が作成できます。 前回ご紹介した「シェイディングされたねじ山」の表示を させていると、モデルに縞模様が現れて、 設定した長さにねじができていることが確認できます。   前回と今回のやり方を合わせると、図面にした時に上記ビューが作成できます。 今回はネジ部の作成方法をご紹介しました。  ...

【モデリング】スケッチの余分な線を修正する

今回はスケッチを描くときに陥る イライラを解消するコマンドをご紹介いたします。 スケッチを描く際に 余分な線を追加してしまうことがありませんか? 書き残しや 二重に線を引いてしまう等。 スケッチ画面上で簡単に見つけることが出来ればいいのですが、 目視だとなかなか見つけられない場合があります。 このような余分な線が残っていると スケッチが完全定義になりません。 余分な線が残っているのか見つけられない場合、 それを簡単に解消するコマンドがあります! 「スケッチ修復」です。 それでは操作を見ていきます。 コマンドマネージャーのスケッチタブより 「スケッチ修復」をクリックします。 ※コマンドマネージャーにない場合は、メニューバーから 「ツール」→「スケッチツール」→「スケッチ修復」 を選択してください。 書き残し等とび出した線の箇所が 虫眼鏡ツールでズームになって表示されます。 そこから不要な線を選択して削除します。 同じように他にもないか調べていきます。 画面上にこのようなダイアログボックスが現れています。 まだ余分な線がある場合、この矢印で送って調べることが出来ます。 修正が終了したら、 ダイアログボックスのキャンセルボタンを押します。 次に2重に引いてしまった線など重複した線について。 こちらを探すのは難しいことですが、 実は「スケッチ修復」コマンドを実行すると同時に 自動的に削除されています。 余分な線が削除できました。 ぜひ試してみてくださいね。...

非アクティブスケッチの色の変更方法

部品やアセンブリなどのモデル作成の際、 スケッチをレイアウト用として参照すると便利です。 一方で、複雑な形状や部品点数が多いモデルになってくると スケッチが見えにくくなり、操作に困ることがあります。 そこで今回は、システムオプションから 非アクティブスケッチの色を変更する方法をご紹介します。 モデル作成時、編集中ではないスケッチの色はグレーです。 この編集中ではないスケッチを「非アクティブスケッチ」といいます。 (編集中のスケッチはアクティブスケッチ) モデルと非アクティブスケッチの色が同じグレー系なので 同化してしまい、見えにくいです。 そこで、 非アクティブスケッチの色を変更して見えにくさを解消してゆきます。 オプションをクリックします。 メニューから 色 をクリックします。 色スキーム設定の項目から「スケッチ、非アクティブ」を選択し、編集ボタンをクリックします。 色の設定ウインドウでグレーと区別しやすい色を選択し、 OKボタンをクリックします。 事例はピンクを選択しています。 OKボタンをクリックして、オプションを閉じます。 非アクティブスケッチが見えやすくなりました。 いかがでしたか? お好みの色で設定をお試しくださいね。 *****お知らせ***** 大好評をいただいております、 【よくわかる!SOLIDWORKS 図面】 “お得な3巻セット”を更にキャンペーン価格で 買えるのは6月末までです。 ↓ ↓ ↓ https://cadrise.jp/dvd/dvd_zumen_lp/...

モデリングの方法色々

こんにちは。アドライズの中澤です。   久しぶりの投稿になってしまいました。 私たちはこの夏、数人の大学生をインターンシップ生として 迎えておりました。   実務を体験していただきましたが、 どの学生さんも学校などですでにSOLIDWORKSは 使えるようになっている優秀な方ばかり。 でも、一応お伝えするにあたりレベルチェックは させて頂きたい、と最初に練習問題を出題させていただきました。   そこで、学生さんたちにお伝えさせていただいた内容が 好評でしたので、ここでもお伝えさせていただきたいと思います。     かなり簡易な形にしていますが、皆さんだったらこの形、 どんなアプローチで作成しますか? 色々なやり方があると思います。 学生さんがやってた方法や弊社が推奨する方法を混ぜて、 まずは3択。あなたならどれで作りますか?   方法1:断面形状を作って回転で作成 方法2:頭と胴体を別々のフィーチャーで作成 方法3:全体の形を作ってから削る   では、1つづつ見ていきましょう。 ※その形が出来ていることには違いが無いので どれも間違いではないことを先にお伝えさせてください。 ここでは、より効率的であったり、シンプルで分かりやすく、 設計変更がしやすいという、実務に向いた設計手法として 弊社の推奨するやり方をご案内させて頂いております。 方法1:断面形状を作って回転で作成 円形の形状の場合の作成手順としては、 このやり方を取られる方も多いのではないかと思いますが、 これだと形状が複雑である場合に応用が利きにくいため、 今回のような単純形状以外には向いていないと考えられます。 設計変更が生じた場合、どこか1箇所でも寸法を 変えただけで他のところまで変えなくてはいけなくなる可能性があり、 制御が難しくなる方法といえるからです。   方法2:頭と胴体を別々のフィーチャーで作成 2つのフィーチャーがくっついている形状にも見えるので このような作成を選ぶ場合もありますよね。 しかし、実際の加工を考えたらどうでしょうか。 2つの塊をくっつけて作るということはしません。 また、図面を見ても、頭の部分の寸法は 記載されていません。 簡単に推測できる部分ではありますが、 図面どおりに作ることを考えた場合、 こういった方法も現実的ではないと言えます。 方法3:全体の形を作ってから削る アドライズがお勧めする手法が最後のコチラです。 最大の大きさのところで円筒形を作り、 そこからカット、カット、で形を作り上げていきます。 方法2でも少しふれましたが、実際の加工工程と 同じにしています。     完成した形だけを見ればどれも同じですが、 色々な作り方があります。 実際の現場では、設計変更や、複数人で作り上げるなど、 学生とは違う場面が多々あります。 誰が見ても分かりやすく、作りやすい形状であることも 大事な要素であると考えます。   ご参考になれば幸いです。                ...