図面

図面にロゴをコピーして貼りつける-DXF_SOLIDWORKS

前回のSOLIDWORKS操作マニュアルでは 企業やブランドのロゴの 図を挿入する方法 をご紹介いたしました。 記事はこちらから → 図面にロゴを挿入する-図_SOLIDWORKS   今回は図面シートフォーマットに、企業やブランドのロゴの DXFデータをコピーして貼りつける方法 をご紹介いたします。 完成図はこちら   操作方法 ファイル形式がDXFのロゴを挿入します。 まず、AutoCADなどの2D-CADでDXF ファイルを開きます。   コピーして貼りつけたいエンティティ(今回はロゴ)を選択し、クリップボードにコピーをします。 (AutoCADではCOPYCLIPコマンド、ショートカットキーは、 Ctrl + C です。)   SOLIDWORKSでコピーをしたエンティティ(今回はロゴ)を貼りつけるための 図面ドキュメントを開きます。 ※AutoCAD のDWGまたはDXFファイルは、SOLIDWORKSの 部品、アセンブリ、図面ドキュメントにエンティティをコピー&ペーストできます。   今回は図枠と同じシートフォーマットにロゴを挿入したいため、 シートフォーマットタブから「シートフォーマット編集」をクリックし、 シートフォーマットの編集に入ります。   メニューバー →編集 →ペースト を選択し、貼り付けます。 (ショートカットキーは、 Ctrl + C です。)   図面上にロゴマークが貼りつきました。 (ロゴはブロックとして貼りつきます。)   もう一度「シートフォーマット編集」をクリックし、シートフォーマットに編集に入り、   ロゴをドラッグして位置や、 PropertyManagerの パラメータ - ブロックスケール で大きさを変更します。   「シートフォーマット編集」をクリックし、シートフォーマット編集を終了します。   ぜひお試しください。   ...

図面にロゴを挿入する-図_SOLIDWORKS

大半の企業はオリジナルの図枠を保持しています。 そこで今回は、図面シートフォーマットに 社名やブランドのロゴを挿入する方法をご紹介いたします。 ※SOLIDWORKSの図面ドキュメントでは図枠のことをシートフォーマットと呼びます。 完成図はこちら     操作方法 シートフォーマットタブから「シートフォーマット編集」をクリックし、 シートフォーマットの編集に入ります。   こちらのロゴマークを挿入します。(ファイル形式は.jpegです。)   メニューバー →挿入 →図 を選択します。 ※このコマンドでは、図 (.bmp, .gif, .jpg, .jpeg, .tif, .tiff, .wmf, .png, .psd) を挿入できます。   ダイアログボックスが現れます。 挿入したいファイルを選択し、「開く」をクリック。   スケッチ図PropertyManagerが表示され、図面上にロゴマークが挿入されます。   下記を使用して図をドラッグしてロゴマークの大きさを調整します。 ■スケッチツールを使用 スケールツールは、図のサイズの変更に使用する各端点にハンドルがある作図線のことです。 ■アスペクト比固定 選択すると縦横比が固定されます。 図を配置をしたい位置にドラッグして移動します。 (ポインタが十字矢印のときに移動できます。) 大きさと位置が決まったら、「OK」ボタンをクリック。   ロゴマークが挿入できました。   シートフォーマット編集を終了します。   まとめ さらに、テンプレートで保存をしておけば、ロゴマークの入った図面を雛形として使用できますね。 ファイル →指定保存 →図面テンプレート(*.drwdot)で保存をします。 また、オリジナルの図面テンプレートの作成方法は下記の図面教材でご紹介しています。 ご活用いただけましたら幸いです。 ■書籍「よくわかる3次元CAD SOLIDWORKS演習 図面編」 ■DVD「よくわかる!SOLIDWORKS図面3 【設定編】」 ...

図面に用いる線の太さを変更する_SOLIDWORKS

日本の機械図面は概ねJIS規格を基準にしています。 図面に用いる線は線の形状と太さによる種類があり、これらを組み合わせて使用します。 ――――――――――――――――――――――――――――――――――――――――― 線の形状: 実線・破線・一点鎖線・二点鎖線 線の太さの種類: 細線・太線・極太線 太さの比率: 1:2:4 太さの基準: 0.13mm,0.18mm,0.25mm,0.35mm,0.5mm,0.7mm,1mm,1.4mm,2mm ――――――――――――――――――――――――――――――――――――――――― 太さの使用例として、 細線を0.25mmとした場合、太線は0.5mm、極太線は1mm。 また、線の形状は用途によって規定されています。 例えば、品物の外形を表す外形線は太い実線というように。   ところが・・ SOLIDWORKSのデフォルト設定では、細線が0.18mm、太線が0.25mmです。 比率は、1:1.388‥  図面に表すものの形状によっては用途の区別がつきにくいですね。 そこで、線の太さを変更する方法のご紹介です。 今回は、SOLIDWORKSの図面ドキュメントで、外形線の太さを0.25mmから0.35mm に変更します。   線のフォント   メニューバーから「オプション」をクリック。 システムオプションのダイアログボックスが開きます。 タブを「ドキュメントプロパティ」に切り替え、「線のフォント」をクリック。 エッジのカテゴリから「可視エッジ」を選択します。 「線の太さ(H):」をプルダウンから「0.35mm」に変更し、 「OK」をクリックしてダイアログボックスを閉じます。 ※可視エッジ=SOLIDWORKSでは外形線です。 ※今回は関係ありませんが、スタイル(S):=線の形です。   外形線の太さが変わりました。   変更後   変更前 この方法は、既に書き上げた図面にも有効ですよ。 お試しください。   ...

3Dモデルにサイズ公差を入れる_SOLIDWORKS

3Dモデルでサイズ公差を確認するときは どのようにしていますか? 紙図面や2D図面からモデルを作成した場合は 図面を見て確認していると思いますが、 「3Dモデルに入っていれば便利だな」 と感じることはありませんか?   そんなときに有用なのがこちら▼ ――――――――――――――― 「公差/少数位数」 ―――――――――――――――   さっそくサイズ公差を付記してみましょう 今回は、穴基準はめあい方式の軸の許容差を入れます。 基準寸法に軸の公差クラスと許容差の数値が付加します。 まず、モデルに付加した寸法を表示します。 ※現在は図示サイズ(基準寸法)のみでサイズ公差は入っていません。 公差を入れたい寸法「φ8」をクリックし、選択状態にします。 PropertyManagerの「公差/少数位数」を開き、   「公差のタイプ」に「はめあい公差」を選択します。   「軸基準はめあい」にプルダウンリストから「g6」を選択します。   「括弧で表示」のチェックボックスにチェックを入れ、プロパティを閉じます。   これでサイズ公差を入れることができました。 寸法を表示すると、基準寸法の次に、軸の公差クラスと許容差の数値が付加されています。   まとめ いかがでしたでしょうか。 モデルにサイズ公差を入れておけば、設計途中でも簡単に確認ができ、 流用設計の際もわかりやすいですね。 また、このモデルから図面を作成した際にも モデルアイテムで寸法を挿入すると 寸法軸の公差クラスと許容差が自動的に入るので使い勝手がいいですよ。 ぜひ試してみてください。 ...

ノックピンの位置決め穴の作成方法

機械や装置の心出しや位置決めにはノックピンを使用しますが、 みなさんはどのように位置決め穴を作成していますか。 穴を「押し出しカット」コマンドで作成して、 図面を作成した場合は下図のようになります。 この場合、ダウエル穴記号は 「ダウエル穴記号」コマンドで手動で追加しなければいけません。 ですが、モデル作成者とは別の人が図面を作成する場合、 通し穴なのか位置決め穴なのかは3Dモデルからは判断できませんよね。 今回は、そんな際におすすめのコマンドをご紹介します。   穴ウィザード(ダウエル穴) まず、位置決め(ノックピン)穴を作成するモデルを開きます。   穴を作成します ① 穴を追加したい面を選択 ② 穴ウィザードをクリック   ③ 穴ウィザードのPropertyManagerに変わります。 「タイプタブ」で、穴タイプのパラメータを設定します。 ーーーーーーーーーーーーーーーーーーーーーーーー ※ 詳細項目にて下記を選択します。 穴タイプ:穴 規格:JIS 種類:ダウエル穴 ----- 穴の仕様へ設計値を選択 サイズ:φ5.0 (今回は「 φ5H7 」を選択) ----- 押し出し状態:全貫通 ーーーーーーーーーーーーーーーーーーーーーーーー   ④「位置タブ」に切り替えて、穴位置を決めます。 OKをクリックして穴をあけます。   穴あけ作業としてはこれで終わりです。 モデルを一見するといつもと同じ穴ですが・・・   図面を作成すると・・・ 図面ビューにダウエルピン記号が追加されています。   まとめ 「穴ウィザード」コマンドで穴タイプの種類に「ダウエル穴」を選択すると 図面ビューの作成時にすべてのダウエルピン記号を自動的に作成できます。 是非、ノックピンの位置決め穴をあける際にお試しください。   また・・・ 「押し出しカット」コマンドで作成した穴の図面にダウエルピン記号を挿入するには、 メニューバー/挿入 →アノテートアイテム →「ダウエル穴記号」です。 ...

拡大/縮小のマウスホイール操作を反転する

デフォルト設定は・・ 拡大/縮小はマウスのホイールボタン(中ボタン)で行います。 デフォルトの操作は、マウスポインタのある位置を中心に、 ・奥に転がす  → 縮小 ・手前に転がす → 拡大   今回は、他種アプリケーションをご使用の方で、 “拡大と縮小を思うようにコントロールできない” という方にご覧いただきたい マウス操作を下記のように反転したい場合の変更方法です。 ・奥に転がす  → 拡大 ・手前に転がす → 縮小   変更方法 メニューバーからオプションをクリック。   システムオプションタブ → 表示 から、 「マウスホイールによる拡大/縮小を反転」にチェックを入れ、「OK」をクリックします。 ※デフォルトではチェックが入っていません。 ※システムオプションはPCに依存する設定です。 SOLIDWORKSを終了して次回起動したときにも有効です。   設定が変更できました ・奥に転がす  → 拡大 ・手前に転がす → 縮小 これで操作性が上がる方もいらっしゃるのではないでしょうか。 お試しください。...

表示パネルで作業効率アップ!

表示パネルとは 「表示パネル」を使用すると、部品、アセンブリ、図面ドキュメントで 設定をした様々な表示設定をすばやく確認することができます。   前回は、部品を透明化する方法をご紹介しました。 →アセンブリで部品の透明度の変更する しかし、複数の部品を透明にしていくと、 どの部品を透明にしたのかわからなくなる場合があります。 そこで、「透明化した部品を確認する方法」を例に、 「表示パネル」をご紹介します。   表示パネルを使ってみよう 「表示パネル」はデフォルトでは折りたたまれています。 そこで、表示パネルを展開します。 FeatureManager デザインツリー上部のタブの右側にある > をクリック。 ※表示パネルを折りたたむには < をクリックします。   透明化した部品は、「透明度」の列にアイコンが表示されます。   現在、サブアセンブリ「コンテナ組立」は透明化をしています。   透明化を解除するには、「表示パネル」の解除したい部品や サブアセンブリの行のアイコンをクリックします。   透明度アイコンが消え、   モデルの表示が元に戻ります。   まとめ また、「表示パネル」では、透明度の他にも 非表示/表示、表示モードや外観なども確認できます。   中でも、 非表示/表示 の設定は、 アイコンをクリックするごとに 素早く部品やボディ、スケッチ、平面などの 非表示と表示の切り替えができ、とても便利です。 ぜひお試しください。 ...

ファイル名の変更方法(2) ― Windows Explorerファイルショートカットメニュー

以前に部品やアセンブリのファイル名を Windows Explorerで直接ドキュメントの名前を変更した場合の 危険についてご紹介しました。 → ファイルの名前の変更による罠!?   ではどうやって名前を変更するのか?・・・ そのひとつに下記変更方法があります。 ・SOLIDWORKS2019 まで:Windowsスタートメニュー → SOLIDWORKS Explorer ・SOLIDWORKS2020 から:Windows Explorer のファイルショートカットメニュー ( ※ SOLIDWORKS Explorer は2020よりWindowsスタートメニューからなくなりました。) 今回は SOLIDWORKS2020 を使用して、 Windows Explorerのファイルショートカットメニュー から変更する方法をご紹介します。   やりたいこと:ファイル名の変更 ここに「A」と「B」という名前の部品ドキュメントを組み付けたアセンブリドキュメントがあります。 組み付けている部品ドキュメントの名前を変更します。 では実際に Windows Explorer から「B」部品の名前を「C」に変更してみましょう。   部品ドキュメントの名前を変更する ― Windows Explorerファイルショートカットメニュー ファイルを右クリック。 ショートカットメニューから「SOLIDWORKS」→「名前変更」をクリック。   「ドキュメントの名前変更」ダイアログボックスが現れます。 「次に変更」欄に新しい名前を入力します。 ※拡張子は削除してしまっても問題ありません。 入力が終わったら「OK」をクリック。 これでドキュメントの参照関係を保ったまま、名前の変更は終了です。 Windows Explorer上でも名前の変更ができたことがわかります。 アセンブリドキュメント「AB組立」を開いて確認してみましょう。 「再構築」をクリックすると、部品の名前が変わります。 問題ありませんね。   この方法の注意点 参照している部品やアセンブリをSOLIDWORKSで開いていると 下図の警告が現れます。 ファイルの名前を変更する前には、 開いている部品やアセンブリを保存して閉じておく必要があります。   ぜひお試しください。 次回は、FeatureManagerデザインツリーを使ったファイル名を変更する方法についてご紹介します。 お楽しみに! ...

【図面テクニック】狭いところへの寸法記入方法

今回は図面ドキュメントで使えるテクニックのご紹介です。 寸法補助線の間隔が狭くて寸法記入の余地がない、 例えば下図の場合の記入方法です。 1.矢印の代わりに黒丸を用いる場合 2.引出線と参照線を用いて記入する場合 さっそく操作方法です 1.矢印の代わりに黒丸を用いる場合 図の箇所は寸法補助線の間隔が狭いです。 矢印が重なりわかりにくいですね。 “寸法補助線の間隔が狭くて矢印を記入する余地がないときは、 矢印の代わりに黒丸または斜線を用いてもよい“ と製図教科書に記載があるのでこれを行います。 操作がしやすいように寸法数値4の寸法補助線は移動します。 寸法数値5を選択状態にして矢印の丸印を右クリック。 メニューから「小黒丸」を選択します。 左側の寸法数値5も同様に行います。 また、この場合の寸法数値4の寸補助線は矢印をつけないルールです。 寸法数値を選択状態にして矢印の丸印を右クリック。 メニューから「なし」を選択します。 左側の寸法補助線も同様に行い、寸法補助線を移動して戻して完成です。   2.引出線と参照線を用いて記入する場合 図の箇所のような寸法補助線の間隔が狭い場合に有効です。 “引出線には引き出す側に矢印をつけず、寸法数値は参照線の上側に記入する” と製図教科書に記載があるのでこれを行います。 寸法数値10を選択状態にします。 プロパティから、「オフセットテキスト」をクリック。 参照線が現れ、寸法数値が参照線の上側に移動します。 寸法数値が選択状態のまま矢印の丸印を右クリック。 メニューから「なし」を選択します。 左側の寸法補助線も同様に行い、参照線の配置を整えて完成です。 まとめ 狭い箇所の寸法記入方法は、 ・矢印の代わりに小黒丸を用いる ・参照線を利用して寸法値を入れる場所をスペースのある場所に移動させる (この場合は引出線の引き出す側の端には黒丸などの何もつけないようにする) また、あわせ技で使うと便利な機能はこちら → 【図面テクニック】寸法を同一線上に整列させる方法 お試しください。...

ファイルの名前の変更による罠!?

アセンブリを行ったあとに うっかりファイルの名前をつけ間違えていることに気がつき、 “部品ドキュメントのファイル名を変更したい” といったことはありませんか? そのようなときSOLIDWORKSの理解が浅いと、 他のアプリケーションのファイルと同じように Windows Explorer(ウィンドウズ エクスプローラ)から 名前を変更してしまいますよね。 今回は、Windows Explorerでドキュメントの名前を変更した場合の 危険とその後の対処方法についてお話いたします。 部品ドキュメントの名前を変更する ここに「A」と「B」という名前の部品ドキュメントを組み付けた アセンブリドキュメントがあります。 組み付けている部品ドキュメントの名前を変更します。 Windows Explorerから、「B」部品の名前を「C」に変更します。 その後、アセンブリドキュメント「AB組立」を開きます。 すると・・・ 下図のダイアログボックスが現れます。 ここで何も選択しないと・・・ 開かれたアセンブリドキュメントでは、 ツリーの部品「B」には警告マークがつき抑制されています。 これは、ドキュメントの参照関係がわからなくなってしまったからです。 (所謂リンク切れってやつですね・・) 再度ドキュメントの参照関係をつける そこで、名前を変更した部品を再指定し、改めて部品を認識させます。 部品「B」をクリックし、部品「B」の抑制解除をクリック。 すると・・・ ダイアログボックスが現れます。 「ファイルの参照」をクリック。 部品「C」を指定して、「開く」をクリック。 部品「C」に変更されました。 アセンブリドキュメントを再度保存してドキュメントを閉じます。 もう一度、アセンブリを開いて確認をすると、 先ほどのダイアログボックスは現れません。 今度は参照関係が崩れていない(復元できた)ことがわかります。   まとめ いかがでしたか。 ドキュメントの参照関係って怖いですね・・・ うっかりリンク切れを起こさないように ファイルの名前を変更する際には、 ドキュメントの取り扱いには注意してくださいね。 ファイル名を変更するこのほかの方法についても次回ご紹介予定。 お楽しみに! ...