SOLIDWORKS操作マニュアル

図面の部品表をカスタム

コンフィグレーションでサイズ違いのボルトを作成し、 アセンブリして図面化する・・・ その際、 「部品番号を変更させたい」 「表示項目を変更したい」 といったこと、ありませんか? 今回は、部品表をカスタムする方法をお伝えします。 頂いた質問はこちら =============== 2D図面で、アセンブリの部品表を 作成するときにとある部品の使い分けを行いたい場合、 同じバルーンの数字で複数の部品を 指定させることはできるのでしょうか。 製品Aに部品aが使われていたとして、 場合によってはa'を使いたいとした場合、 部品表に同じバルーンのNoで 部品aと部品a'を両方表示させたい。 何か手段・方法があれば教えていただけないでしょうか。 =============== ありがとうございます。 例えば、上のようなアセンブリ(メールセミナーで使用したコンフィギュレーションの六角ボルトを使用しています。)を作成して図面表を作る場合。 (画像では分かりやすいよう、ボルトは浮かせて作成しています) こんな風に部品番号が別々でつきます。 でも、ある操作により、↓のように部品番号を操作できるようになります。 ある操作とは、各部品に文書情報を付加し、それを表示させることです。 部品ドキュメントでファイルプロパティから、 「コンフィギュレーション特有」タブ 設定対象に該当するコンギギュレーションを選択 (複数の場合は各コンフィギュレーションに下記設定を行います) プロパティ名をダブルクリックして「部品番号」 タイプに入力したいもののタイプ(今回はアルファベットを使用したのでテキストです。) 値/テキスト表現に「2-a」など表示させたい部品番号 OK この作業を他の部品に行います。 コンフィギュレーションではない部品には隣の「ユーザー定義」タブから 同様の設定が可能です。 これで表示の準備は整いました。 図面ドキュメントに戻り、部品表を表示させましょう。 「アノテートアイテム」タブ内「テーブル」より、「部品表」をクリック。 部品表を作成する対象のモデルビューをクリック 部品表タイプ「部品のみ」 部品コンフィギュレーションのグループ化は 「同一部品のコンフィギュレーションを別アイテムとして表示」を選択 OK まずはこのような部品表を作成し、任意の場所でクリック。配置します。 表の上にカーソルがあると水色の枠が表示されるので、 Aの上でマウスが図のように変化したらダブルクリック。 列タイプを「ユーザー定義プロパティ」にすると、 下に「プロパティ名」は現れるので部品番号を選びます。 先ほど各部品につけた部品番号に変わりました。 同じように行にカーソルを併せて「並べ替え」を行います。 完成しました。 さらにバルーンをつけるには、、 「複数インスタンスを無視」の選択を解除。 バルーンテキストも 「ユーザー定義プロパティ」にし、 「部品番号」にしておきます。 付けた番号が反映されました! 如何でしたか? コンフィギュレーション自体の解説もメールセミナーで 行っておりますので、そちらも併せてご利用ください。...

下のモデルのエッジが点線で表示されるのを回避する

今回も質問の回答をしていきます。 T様ありがとうございました。 今回のご質問は、表示に関するものです。 *************** コンベアのアセンブリを表示していて、 表示倍率を引き気味に(全体見渡すよう)した場合、 1mmくらいの厚さのコンベアベルトの下にある部材のエッジが 破線のように見えてしまいます。 表示を拡大すると徐々にエッジが消えていくのですが、 全体見渡し画面で、エッジを消したいです。 今私ができる対策としては、エッジを表示したくない部品のみを シェーディング表示することで破線のようなものが消えます。 しかし、この方法ですとシェーディング表示された部品が ぼやけて見えてしまい部品の存在がわかりにくくなります。 部品をシェーディング表示にせず、破線のようなものを消す方法を教えて下さい。 よろしくお願いいたします。 *************** どういうことかというと、下図のようになにかしらの部品の上にベルトなど 薄いものが覆う形状ってあると思います。 実際これをSOLIDWORKSで作ってみると。。 このように、下のモデルのエッジの線が出てしまうのです。 (拡大すると出ません) T様のようにシェイディング表示にすると、 確かに線は消えますが、ぼやけた印象になりますよね。 更に、前回図面でご紹介した「正接エッジの表示/非表示」を モデルに対しても「削除」設定にしてみると。 ダメでした。 ******* 原因と対策 ******* こうなってしまうのは、 ベルト部分の薄さに原因があります。 あまりに薄いので出てきてしまうんです。 対策としては2つ考えられます。 ですが申し訳ありません。 どちらの対策も設計を変えてしまうような方法になります。 (1)厚みを増やす (2)クリアランスをあける どちらも”1mm”で効果が出ますが、その1mm分設計とは変わりますので プレゼン資料に使用するなどで絵的なものが欲しいときのみ有効な手段です。 (T様のようなアセンブリの場合は厚みを増やす方が有効と思われますが、  どっちの方法で消すのがいいかはモノによりますのでご検討ください。  弊社も資料画像などはこのように少し変えて撮っています。) (1)厚みを0.1mmから1mmへ増やした場合  (2)間に1mmのクリアランスをつけた場合 このように消えました。 ただ、さらに縮小させると結局出てくるんです。。 必要なサイズで表示されないよう調整ください。 明確な回答にならず申し訳ございませんが、 これも1つの方法ということでご案内させて頂きました。 上記の方法は外観的な対策となります。 設計データは変更しない方がいいので、 外観用のデータを用意しお試しください。 また、ほかの回避方法を見つけましたら ご案内していきたいと思います。  ...

【図面】Rの線を表示/非表示

今日はレジン様から頂いたご質問に 回答させて頂きました。 2D→3Dへ移行した方にとっては ソフト間の相違に戸惑いや不便を感じることも 少なくないと思います。 =============== メール講座で、簡単にレベルアップでき、 かなり感謝しております。 レベルの低い質問かもしれませんが、、 2Dの図面で、R部分が実線で表示されるのを、 無くす方法(設定)はあるんでしょうか? 立体図の時はR部分に線が表示されていても、 問題は無いのですが、正面や側面図に R部分が実線表示されると、困ってしまいます。 他社の3Dソフト(インベンター)等は 2DでR部分の実線表示はされないので、 ソリッドワークスでも、設定可能なんでしょうか? =============== はい。可能です。 しかも、色々選べます。 まずは、どんなものがあるか並べてみますね。 使った形状はコレ。 設定を変更しないデフォルト状態で図面にすると ↓このようにR部分、実線が入ってますよね。 「表示」 この線を「正接エッジ」といいます。 それを、 「フォント使用」 「フォント使用-端点の非表示」(拡大表示) 「削除」 このように選択が可能になります。 <<設定方法>> 設定から システムオプション→図面→「表示スタイル」 その中に「正接エッジ表示」というメニューがあります。 デフォルトでは「表示」になっていますので、 必要に合わせて設定を変更してください。 ***** また、この設定は「システムプロパティ」の設定になり、 SOLIDWORKS共通のため次回起動時も継続となります。 この設定は「新規でモデルビューを作る」ときのみ反映されます。 既存の図面内のビューでこの設定を切り替えたいときは 下記画像のようにビューを右クリックから「正接エッジ」で切り替えられます。 (ビュー:あらゆる方向からモデルを投影した図のこと。図面の絵を選択してアクティブになった点線枠の中)  ...

画像をなぞってスケッチを描く方法

本日のご質問、 デザイン画を取り込んで、なぞるように スケッチができる方法をご紹介します。 ============== よく動画で写真を取り込んでマウスの モデリングをしているのを見ていますが 解説が英語なのでイマイチ分かりづらい のですができましたら解説のほど 宜しくお願い致します。 又写真はどういう風に変換し 取り込んでいるか、お願い致します! ============== ご質問ありがとうございます。 (弊社発行のメルマガ読者様限定で 募集した質問に回答しています) 写真、基本的にピクチャファイル(jpg,png,gif,bmpなど) であれば使えます。 今回はシンプルで曲線のある形状としてハートを 例題にしました。(男性の方も是非トライしてくださいね) 上の画像を右クリックで画像を保存してください。 では、SOLIDWORKSで新規部品ドキュメントをひらいてください。 まずは画像の大きさを調整するため作図線で矩形を描いておきます。 (画像全体でも大きさを調整することはできますが、 余白込みになってしまうのでこのように欲しいもののサイズで指定します。) 面を選択してスケッチに入ります。 ツール→スケッチツール→スケッチ図 保存しておいたハートを開きます。 先ほどの矩形の中に納まるよう画像を調整します。 更に、背景の白も消していきましょう。 左のメニュー、下側の透明度の項目を ユーザー定義 にして、 スポイトで背景の白を指定、 透明度を1.00にします。 OKすると だいたいですが、取れました。 ココまでで一旦、このスケッチは終了させてください。 レイアウトスケッチのように、このスケッチは 直接立体化などしないスケッチになります。 (ツリーの名前を変更しておくと分かりやすいですよ!) あとは、またスケッチを新たに開始して スプラインなどで曲線をなぞるように描いていきます。 作成の途中でいらなくなったら非表示にすることも出来ます。 色々展開は出来ると思いますが、 私はドームコマンドを使ってプックリ膨らませてみました。 フリーハンドだけでこういった形状を作るのは難しいですが、 なぞるだけならすぐ出来てしまいますね! 「寸法を入れなくていいの?」 と思う方もいると思いますが、入れなくても大丈夫です。 ただ、一番最初の作図線のように 最大寸法は決めておいた方がいいです。 ****** 弊社で編集しているこの書籍でも詳しく解説してます! ↓こんな複雑な形状のクジラもスケッチ図があれば作れます! 作成過程を少しだけお見せすると、 側面と平面の図を2枚組み合わせて元を作り、 これを立体的に作り込んでいくのです。 こちらはサーフェスなど使って、難易度高いですので 興味ある方は書籍でご確認くださいね。...

ツールボックスの編集

今回はツールボックスの編集方法を お伝えします! (前回紹介したツールボックスの使い方はコチラ) 頂いたご質問↓ =============== toolbox/コンフィギレーション/ユーザ設定の定義/設定/ ファイルの コンフィギレーションの作成と部品作成の区別が今一つ はっきりしません。 (1)toolboxの部品を加工したり、編集する時に、マスターファイルを 上書きしない場合には、 部品作成を指定し、データを保存するフォルダ を作成(指定)すればいいと理解していいでしょうか。 (2)また、sw2007で作成したデータをsw2007というフォルダに元のデータ と編集したデータを保存。 sw2013で呼び出すとすると、2013側のtoolbox側で部品作成として のフォルダをsw2007 に指定する必要がありますか? この場合、①を作成せず、sw2007とかsw2013のフォルダに元のデータと 加工したデータを保存する方法では不都合がありますか? (3)システムオプションに穴ウイザード/toolboxがありますが、 ここでのフォルダ  C:\SolidWorks Data\ と  検索boxに チェックを入れるか いれないかの区別が初心者のため理解できません。 =============== (1)ツールボックスの部品の加工、編集方法 まずは編集画面へ。 ツール→Toolbox→コンフィギュレーション 新たなウィンドウが開きますので2.ハードウェアのカスタマイズをクリック。 ここで編集が出来るようになります。 まずは部品の保管先フォルダを作成します。 (※テストというフォルダを作成しました) 元データから編集する場合、元となるデータをコピーして、 作成したフォルダにペーストします。 ⇒ これをクリックすると編集画面になります。 「有効」のチェックはこの部品を使えるようにするかどうか、 「ユーザー定義コンフィギュレーション名を許可」では画像下のコンフィギュレーション名を変更できます。 その他説明やファイル名を変更でき、 「標準プロパティ」ではサイズ、長さなど様々なものを変更できます。 元データを使って編集したい場合はコチラを編集してください。 最後に左上にある保存ボタンで保存します。 部品ファイルで部品を作成した場合は フォルダを右クリックして出てきた「ファイルの追加」で使用できるようになります。 (2)バージョンの違いについて SOLIDWORKSのツールボックスは基本的に バージョンに依存しています。 SOLIDWORKS2016は2016のツールボックス、 2014は2014のツールボックスと、それぞれ参照します。 ですから、バージョンが違うと参照がうまくいかない場合も発生します。 過去バージョンを開いた時、保存について基本的には元データのところに 追加保存もできます。しかし、新規追加する場合は「フォルダの作成」をオススメします。 あとで見たときに分かりにくくなる管理の不便さが発生するからです。 または、ツリーで部品を右クリックし、出てきたメニューから 「構成部品置き換え」にて 現バージョンに修正するなども可能です。 (3)ツールボックスの呼び出しについて バージョンに依存せず、一つのツールボックスだけを参照する 方法もあります。 設定から ツールボックスの画面で出てくる指定フォルダを 変更し、チェックボックスにチェックをいれます。 この設定をしておくと、アセンブリ上で本のマークをクリックすると、 ここで指定したフォルダが開くことになります。 私はSOLIDWORKS2016を使用していたので、デフォルトでは2016が指定されています。 しかし、2015のデータを使いたい、社内のツールボックスを使いたい場合などがあれば そのフォルダを指定して、指定のチェックを入れておきます。 いかがでしたか? 今回の内容はかなりレベルが高いかもしれません^^; 普段使わない方も、ツールボックスを使わなきゃ!という時に 思い出してもらえたら幸いです。...

アセンブリ上でネジを挿入する

⇒⇒⇒⇒⇒⇒ 今回もメルマガ読者様から頂いた質問に回答します。 ========== アッセンブリーで、ツールボックスを使用して、 ネジ、ナットを設置することがあります。 設計変更になり、ねじの長さ、径を変えたい場合です。 元のパーツを後から変更することができないので、 新たにパーツを配置しているのですが、かなり面倒です。 何か良い方法はないのでしょうか? よろしくお願い致します ========== 前回穴ウィザードであけた穴にネジやナットを挿入します。 結論からいいますと、元のパーツから変更出来ます! 最後には変更方法までご案内しているのでご覧くださいね。 では、早速やってみましょう。 前回の要領で穴をあけた部品をアセンブリドキュメントで開いてください。 (M5の穴を座ぐりあり、なしで2箇所に開けました) 早速挿入してみましょう。 1:挿入したい部分をクリックして、 2:画面の右側にあるタブから本のマークをクリック。   Toolboxをダブルクリック。 JISなど使用する規格を選択。 いろんな種類がありますので挿入したいものを選んで ドラッグして近くに持っていきます。 近づけると自動的にはまりますので、マウスをうまく調整してください。 サイズウインドウも出てきますので、確定させます。 ネジが入りました!!!! ※座ぐりがある場合 図の場所を選択してくださいね。 では、変更していきます。 まずは長さの変更。 変更したいネジをクリックすると、 オレンジの矢印が出現します。 この矢印を ドラッグすると長さが変わります。 ネジをM5からM3に変更します。 該当するネジをツリーから右クリック。 出てきたメニューから「Toolbox 構成部品編集」を選択。 サイズのウインドウが出てくるので 選択し直すことができます。 または、画面左側のメニューから 変更できます。↓  ...

2D?3D?穴ウィザードの使い分け

  今日のご質問はこちら! ============== いつもメルマガ楽しみにしています。 幅広い方々が理解して、楽しく進めていけるように 色々工夫なさっていてとても勉強になります。 「アセンブリコマンド 穴シリーズ」についてですが、 一番おききしたいのは「3Dスケッチによる穴位置決めの利点」と 「どんな場合に使用していくのか」という事についてです。 フィーチャーコマンドの穴ウィザードについても 位置決めの際、どうしてはじめから3Dスケッチになってしまうのかがわかりません。 私は同じ平面にしか穴を打ったことがない為、予め面を選択し、 コマンドを起動することで、2Dスケッチのまま位置決めをしています。 でも、通常にコマンドを起動すると3Dになってしまうのは、 きっと3Dの方が使いやすい、または多くのニーズがあるのではないかと 考えてました。 やはり何か使い勝手がいいのでは?それを知らないだけでは??? と思っていますが、いかがでしょうか? ============== いつもお読みいただきありがとうございます。 穴をあけるコマンドはいくつかあり、 アセンブリ上では「穴シリーズ」といいますが、 今回は部品ドキュメント、フィーチャータブ内にある 穴ウィザードで解説をしていきますね。 (基本は同じです)       書いてもらっている通り、穴をあけるには2Dと3Dスケッチ、 両方の方法があります。 それぞれのメリットを確認します。 2D:編集しやすい。 スケッチ面が分かりやすい。 (以上のメリットはかなり重要なので、 2Dで出来るものは2Dを使うことをオススメします。) 3D:円筒面など曲面への穴あけが簡単。 フィーチャーが1つにまとまっているから変更が簡単。 (2Dで難しい時のみ使うという認識でもOK)     やり方も見てみましょう。 まずは2Dでは? このように穴をあけたい面を選択してから に入ります。     出てきた左側のメニューから穴の仕様を決めたら、位置のタブに移ります。 モデルの上にカーソルを持っていくと、穴のプレビューが表示されます。 先ほど選択した面(右側)に穴があけられます。 でも、高さの違う左側にはうまくあけられません。   =============== 他の面にも同じ仕様で穴を開けたい場合などに便利なのが 3Dスケッチを使った方法です。 今度はどこも選択しないでコマンドに入ります。     位置タブに移ると3Dスケッチのボタンが ありますのでクリックします。モデルの穴を開けたい場所をクリック。 ちょっと極端ですが、どの面にも同じ仕様の穴を一度にあけられました。 それぞれの穴は「点」コマンドになっていますので、 スマート寸法で最後に寸法を入力します。(青→黒点に変わります)                 さらに、3Dスケッチが生かされるのは曲面です。 曲面に穴を開けたい場合、3Dは便利です。 これを2Dでやろうとしたら大変ですよね。 3Dならワンクリックです。 あとから位置を決めていくので、 まずは大まかな位置でクリックして配置してください。   さらにここに、拘束を付けます。 拘束を付けるポイントは最初に基準面などの 面か軸と「一致」させることです。 ただ、面とだけだとまだ不足なので寸法も入れます。 点とエッジを選択したくなりますが、 円筒など曲線の場合、円の中心からになりうまく寸法が取れません。 下図のように側面を選択し、点との寸法を入れてください。   これで完全定義された穴が完成しました。 (さらに「円形パターン」を使えば、この円筒上にいくつも穴ができます!) 次回、ここにボルトを入れるなどネジ編に続きます。  ...

左右対称部品を作る方法のご紹介

  今日はメルマガ読者さん限定で募集した SOLIDWORKSに関する質問を解説します。   質問内容はコチラ↓ =============== 部品の設計をする場合、左右対称の部品が多いです。 ○左右対称部品のモデリング、管理方法 ○左右対称部品を使ったアッセンブリの方法 ○左右対称アッセンブリの作成方法、管理 に関して、解説をお願いします。 当方では、左右対称部品に関しては、 L部品作成 ↓ ミラー ↓ ボディー削除(L部品) としてR部品を作成後、コンフィグレーションで L部品、R部品を切り替え出来る形で作業を行っています。 この方法が一般的な方法なのか? 他にも方法があるのか? 推奨する方法は何か 解説していただけるとありがたいです。 =============== ご質問内容にもありましたミラーして元ボディーを削除する方法は 多くの方がやっていると思われますので、 そういった意味では一般的と言えるかもしれません。 しかし、SOLIDWORKSの機能では他の方法もあります! 。。。実は以前の記事に紹介しているコマンドが 今回の回答になりますので、詳しい使い方はリンク先で ご確認をお願いします。 (下記の2つの方法はそれぞれリンクで記事につながっています。) 他の方法(1)部品のミラー 他の方法(2)アセンブリ上で部品をミラー 推奨という点では、それぞれメリットデメリットがあるので、 なんともいえません。 各コマンドを体験して頂いて、ご自身の作業に良い方を ご判断お願いします。   とはいえ、頂いたご質問に対する回答としては 【部品のミラー】が一押しかもしれません。 ◆別ファイルでコピー部品が作成されます。 ◆元の部品に加えた操作はミラー後の部品にも即時全部反映されます。 ◆左右で少し違う形状にしたい場合は、 リンクを切ってコピーすることでミラー後の部品に反映させないこともできます。   とっても便利なコマンドですが、挿入タブ内の あまり見ないところにあるのでまさに隠れた有能コマンドです。 この機会に是非お試しください。...

かたまりの単位で扱うソリッドボディ

https://cadrise.jp/manual/so_manual/spoon03/ 今日は前回までの中で お伝えしきれなかった部分の解説回です。 「ソリッド」、「マージ」、「組み合わせ」、、 これらの用語は【マルチボディ】を理解する上で欠かせないものになります。 何気なく使ってしまっていた用語、しっかり解説していきます!   >マージしてしまうと本体のソリッド(かたまり)と >一体化している状態なのであとで抜き取れなくなります・・・ ↑こんな風に書いていた部分がありました。   【ソリッド】とは、「かたまり」 立体の単位で独立したソリッドを ドキュメント内で扱う時は【ソリッドボディ】といいます。 例えば最初のスケッチから押し出した↓は 1つの「ソリッド」です。(ソリッドボディ)   この時点ではまだ一つしかありませんが、 作業を進めてソリッドを増やしていき、例えばこのとき。 左側のツリーを見ると ソリッドボディが3つになっていることが分かります。 (ソリッドが1つのときにこのメニューはありません) しかし、次のロフトで柄とつぼの薄板を つなげて一つにするので 2つになりました。 (最初につくった押し出しのソリッドと ロフトでつなげたソリッドの2つ) ↓この状態の時です。   もし薄板を作っている時、 □ マージする というチェック項目を付けていたら 一体化しているので別のソリッドにはなっていませんでした。   このように、1つの部品ドキュメント内に複数のかたまりがあることを 【マルチボディ】といいます。     今回は「組み合わせ」というマルチボディ機能を使いたかったので このような作成方法を試してきましたが、 別々の部品ドキュメントに作ってアセンブリで構成することも出来るので、 可能な限りはアセンブリで作成することをオススメします。 それは、マルチボディで作るとかなり慣れた方でないと あとで修正などで手を加える作業の難易度が上がるからです。   得意なものが違うので、作りたい形状に合わせて マルチボディ・アセンブリを選択できるようになるといいですよね。    ...

【回転・ロフト・組み合わせ】スプーンを作ってみよう03

https://cadrise.jp/manual/so_manual/spoon02/ ご好評いただいておりますスプーンの第3弾、 あと少しで完成です! 前回のこの形までは出来ていますか?? 大事な設定をお伝えしていなかったのですが、 この押し出し-薄板フィーチャーの設定画面にある □ マージする のチェックは外しておいてくださいね。 マージしてしまうと本体のソリッド(かたまり)と 一体化している状態なのであとで抜き取れなくなります・・・   今日はひとまずここまでを目指します。 最初はすくう部分のつぼを作っていきましょう。 まずはスケッチですね。 ◆ポイント◆ ・エンティティ変換でレイアウトスケッチをコピーしますが、 先端を少しとび出させます。 (端点をドラッグでスケッチを伸ばせます。その後寸法入力!) ・真ん中のブロックのスケッチはレイアウトの中点までにしてください。 (また端点をドラッグで中点まで縮めます。 うまく縮められない場合は中点に作図線を引いてトリムでもOKです) ・上の図では分かりやすいようオレンジ色で出していますが、 回転の軸になるよう中心線をいれてください。   【回転 ボス/ベース】 上のような設定にします。 ※ここでも「結果のマージ」にチェックが入らないよう注意してください。 このような形になりましたか?↓↓↓ では、柄とつぼを「ロフト」でつなぎます。 この次にやる「組み合わせ」では 要素をくっつけて1つになっている必要があるので オプションのチェックに気をつけてください。 押し出しと回転の薄板を作成するところでは 「マージする」のチェックを外すようお願いしておりましたが、 ここではチェックを入れます。 ただ、チェックを入れるだけではやはり本体のソリッドも 一体化してしまいます。   そこで、設定画面最下部にある 「フィーチャーのスコープ」です。 デフォルトの状態では「自動選択」になっていますが、 チェックを外し、「選択ボディ」をチェック。 2つの薄板(↓の緑と青)を選択します。 こうすることで、本体はマージせず、つぼと柄をつなぐことができます。       できましたか? ここまでできれば、あとはこの2つの要素の重なっている部分だけを抜き出します。 挿入 → フィーチャー → 組み合わせ 要素がしっかり作られていなければ「組み合わせ」を選択できません。 その時は今までの過程をもう一度確認してください。 ブーリアン演算を使って共通部分だけを抜き出しています。 こちら、詳しくは検索してみてくださいね。 最後に柄の端をフィレットで丸めたら完成です! 3回にわたってお伝えしてきましたスプーン、如何でしたか? 一つひとつの手順は分かっていても、 こうやって曲面を作るのはまだまだ大変な作業だったのではないでしょうか。 引き続きみなさんのお役に立てる情報を発信してまいります。  ...