SOLIDWORKS操作マニュアル

ツールボックスの編集

今回はツールボックスの編集方法を お伝えします! (前回紹介したツールボックスの使い方はコチラ) 頂いたご質問↓ =============== toolbox/コンフィギレーション/ユーザ設定の定義/設定/ ファイルの コンフィギレーションの作成と部品作成の区別が今一つ はっきりしません。 (1)toolboxの部品を加工したり、編集する時に、マスターファイルを 上書きしない場合には、 部品作成を指定し、データを保存するフォルダ を作成(指定)すればいいと理解していいでしょうか。 (2)また、sw2007で作成したデータをsw2007というフォルダに元のデータ と編集したデータを保存。 sw2013で呼び出すとすると、2013側のtoolbox側で部品作成として のフォルダをsw2007 に指定する必要がありますか? この場合、①を作成せず、sw2007とかsw2013のフォルダに元のデータと 加工したデータを保存する方法では不都合がありますか? (3)システムオプションに穴ウイザード/toolboxがありますが、 ここでのフォルダ  C:\SolidWorks Data\ と  検索boxに チェックを入れるか いれないかの区別が初心者のため理解できません。 =============== (1)ツールボックスの部品の加工、編集方法 まずは編集画面へ。 ツール→Toolbox→コンフィギュレーション 新たなウィンドウが開きますので2.ハードウェアのカスタマイズをクリック。 ここで編集が出来るようになります。 まずは部品の保管先フォルダを作成します。 (※テストというフォルダを作成しました) 元データから編集する場合、元となるデータをコピーして、 作成したフォルダにペーストします。 ⇒ これをクリックすると編集画面になります。 「有効」のチェックはこの部品を使えるようにするかどうか、 「ユーザー定義コンフィギュレーション名を許可」では画像下のコンフィギュレーション名を変更できます。 その他説明やファイル名を変更でき、 「標準プロパティ」ではサイズ、長さなど様々なものを変更できます。 元データを使って編集したい場合はコチラを編集してください。 最後に左上にある保存ボタンで保存します。 部品ファイルで部品を作成した場合は フォルダを右クリックして出てきた「ファイルの追加」で使用できるようになります。 (2)バージョンの違いについて SOLIDWORKSのツールボックスは基本的に バージョンに依存しています。 SOLIDWORKS2016は2016のツールボックス、 2014は2014のツールボックスと、それぞれ参照します。 ですから、バージョンが違うと参照がうまくいかない場合も発生します。 過去バージョンを開いた時、保存について基本的には元データのところに 追加保存もできます。しかし、新規追加する場合は「フォルダの作成」をオススメします。 あとで見たときに分かりにくくなる管理の不便さが発生するからです。 または、ツリーで部品を右クリックし、出てきたメニューから 「構成部品置き換え」にて 現バージョンに修正するなども可能です。 (3)ツールボックスの呼び出しについて バージョンに依存せず、一つのツールボックスだけを参照する 方法もあります。 設定から ツールボックスの画面で出てくる指定フォルダを 変更し、チェックボックスにチェックをいれます。 この設定をしておくと、アセンブリ上で本のマークをクリックすると、 ここで指定したフォルダが開くことになります。 私はSOLIDWORKS2016を使用していたので、デフォルトでは2016が指定されています。 しかし、2015のデータを使いたい、社内のツールボックスを使いたい場合などがあれば そのフォルダを指定して、指定のチェックを入れておきます。 いかがでしたか? 今回の内容はかなりレベルが高いかもしれません^^; 普段使わない方も、ツールボックスを使わなきゃ!という時に 思い出してもらえたら幸いです。...

アセンブリ上でネジを挿入する

⇒⇒⇒⇒⇒⇒ 今回もメルマガ読者様から頂いた質問に回答します。 ========== アッセンブリーで、ツールボックスを使用して、 ネジ、ナットを設置することがあります。 設計変更になり、ねじの長さ、径を変えたい場合です。 元のパーツを後から変更することができないので、 新たにパーツを配置しているのですが、かなり面倒です。 何か良い方法はないのでしょうか? よろしくお願い致します ========== 前回穴ウィザードであけた穴にネジやナットを挿入します。 結論からいいますと、元のパーツから変更出来ます! 最後には変更方法までご案内しているのでご覧くださいね。 では、早速やってみましょう。 前回の要領で穴をあけた部品をアセンブリドキュメントで開いてください。 (M5の穴を座ぐりあり、なしで2箇所に開けました) 早速挿入してみましょう。 1:挿入したい部分をクリックして、 2:画面の右側にあるタブから本のマークをクリック。   Toolboxをダブルクリック。 JISなど使用する規格を選択。 いろんな種類がありますので挿入したいものを選んで ドラッグして近くに持っていきます。 近づけると自動的にはまりますので、マウスをうまく調整してください。 サイズウインドウも出てきますので、確定させます。 ネジが入りました!!!! ※座ぐりがある場合 図の場所を選択してくださいね。 では、変更していきます。 まずは長さの変更。 変更したいネジをクリックすると、 オレンジの矢印が出現します。 この矢印を ドラッグすると長さが変わります。 ネジをM5からM3に変更します。 該当するネジをツリーから右クリック。 出てきたメニューから「Toolbox 構成部品編集」を選択。 サイズのウインドウが出てくるので 選択し直すことができます。 または、画面左側のメニューから 変更できます。↓  ...

2D?3D?穴ウィザードの使い分け

  今日のご質問はこちら! ============== いつもメルマガ楽しみにしています。 幅広い方々が理解して、楽しく進めていけるように 色々工夫なさっていてとても勉強になります。 「アセンブリコマンド 穴シリーズ」についてですが、 一番おききしたいのは「3Dスケッチによる穴位置決めの利点」と 「どんな場合に使用していくのか」という事についてです。 フィーチャーコマンドの穴ウィザードについても 位置決めの際、どうしてはじめから3Dスケッチになってしまうのかがわかりません。 私は同じ平面にしか穴を打ったことがない為、予め面を選択し、 コマンドを起動することで、2Dスケッチのまま位置決めをしています。 でも、通常にコマンドを起動すると3Dになってしまうのは、 きっと3Dの方が使いやすい、または多くのニーズがあるのではないかと 考えてました。 やはり何か使い勝手がいいのでは?それを知らないだけでは??? と思っていますが、いかがでしょうか? ============== いつもお読みいただきありがとうございます。 穴をあけるコマンドはいくつかあり、 アセンブリ上では「穴シリーズ」といいますが、 今回は部品ドキュメント、フィーチャータブ内にある 穴ウィザードで解説をしていきますね。 (基本は同じです)       書いてもらっている通り、穴をあけるには2Dと3Dスケッチ、 両方の方法があります。 それぞれのメリットを確認します。 2D:編集しやすい。 スケッチ面が分かりやすい。 (以上のメリットはかなり重要なので、 2Dで出来るものは2Dを使うことをオススメします。) 3D:円筒面など曲面への穴あけが簡単。 フィーチャーが1つにまとまっているから変更が簡単。 (2Dで難しい時のみ使うという認識でもOK)     やり方も見てみましょう。 まずは2Dでは? このように穴をあけたい面を選択してから に入ります。     出てきた左側のメニューから穴の仕様を決めたら、位置のタブに移ります。 モデルの上にカーソルを持っていくと、穴のプレビューが表示されます。 先ほど選択した面(右側)に穴があけられます。 でも、高さの違う左側にはうまくあけられません。   =============== 他の面にも同じ仕様で穴を開けたい場合などに便利なのが 3Dスケッチを使った方法です。 今度はどこも選択しないでコマンドに入ります。     位置タブに移ると3Dスケッチのボタンが ありますのでクリックします。モデルの穴を開けたい場所をクリック。 ちょっと極端ですが、どの面にも同じ仕様の穴を一度にあけられました。 それぞれの穴は「点」コマンドになっていますので、 スマート寸法で最後に寸法を入力します。(青→黒点に変わります)                 さらに、3Dスケッチが生かされるのは曲面です。 曲面に穴を開けたい場合、3Dは便利です。 これを2Dでやろうとしたら大変ですよね。 3Dならワンクリックです。 あとから位置を決めていくので、 まずは大まかな位置でクリックして配置してください。   さらにここに、拘束を付けます。 拘束を付けるポイントは最初に基準面などの 面か軸と「一致」させることです。 ただ、面とだけだとまだ不足なので寸法も入れます。 点とエッジを選択したくなりますが、 円筒など曲線の場合、円の中心からになりうまく寸法が取れません。 下図のように側面を選択し、点との寸法を入れてください。   これで完全定義された穴が完成しました。 (さらに「円形パターン」を使えば、この円筒上にいくつも穴ができます!) 次回、ここにボルトを入れるなどネジ編に続きます。  ...

左右対称部品を作る方法のご紹介

  今日はメルマガ読者さん限定で募集した SOLIDWORKSに関する質問を解説します。   質問内容はコチラ↓ =============== 部品の設計をする場合、左右対称の部品が多いです。 ○左右対称部品のモデリング、管理方法 ○左右対称部品を使ったアッセンブリの方法 ○左右対称アッセンブリの作成方法、管理 に関して、解説をお願いします。 当方では、左右対称部品に関しては、 L部品作成 ↓ ミラー ↓ ボディー削除(L部品) としてR部品を作成後、コンフィグレーションで L部品、R部品を切り替え出来る形で作業を行っています。 この方法が一般的な方法なのか? 他にも方法があるのか? 推奨する方法は何か 解説していただけるとありがたいです。 =============== ご質問内容にもありましたミラーして元ボディーを削除する方法は 多くの方がやっていると思われますので、 そういった意味では一般的と言えるかもしれません。 しかし、SOLIDWORKSの機能では他の方法もあります! 。。。実は以前の記事に紹介しているコマンドが 今回の回答になりますので、詳しい使い方はリンク先で ご確認をお願いします。 (下記の2つの方法はそれぞれリンクで記事につながっています。) 他の方法(1)部品のミラー 他の方法(2)アセンブリ上で部品をミラー 推奨という点では、それぞれメリットデメリットがあるので、 なんともいえません。 各コマンドを体験して頂いて、ご自身の作業に良い方を ご判断お願いします。   とはいえ、頂いたご質問に対する回答としては 【部品のミラー】が一押しかもしれません。 ◆別ファイルでコピー部品が作成されます。 ◆元の部品に加えた操作はミラー後の部品にも即時全部反映されます。 ◆左右で少し違う形状にしたい場合は、 リンクを切ってコピーすることでミラー後の部品に反映させないこともできます。   とっても便利なコマンドですが、挿入タブ内の あまり見ないところにあるのでまさに隠れた有能コマンドです。 この機会に是非お試しください。...

かたまりの単位で扱うソリッドボディ

https://cadrise.jp/manual/so_manual/spoon03/ 今日は前回までの中で お伝えしきれなかった部分の解説回です。 「ソリッド」、「マージ」、「組み合わせ」、、 これらの用語は【マルチボディ】を理解する上で欠かせないものになります。 何気なく使ってしまっていた用語、しっかり解説していきます!   >マージしてしまうと本体のソリッド(かたまり)と >一体化している状態なのであとで抜き取れなくなります・・・ ↑こんな風に書いていた部分がありました。   【ソリッド】とは、「かたまり」 立体の単位で独立したソリッドを ドキュメント内で扱う時は【ソリッドボディ】といいます。 例えば最初のスケッチから押し出した↓は 1つの「ソリッド」です。(ソリッドボディ)   この時点ではまだ一つしかありませんが、 作業を進めてソリッドを増やしていき、例えばこのとき。 左側のツリーを見ると ソリッドボディが3つになっていることが分かります。 (ソリッドが1つのときにこのメニューはありません) しかし、次のロフトで柄とつぼの薄板を つなげて一つにするので 2つになりました。 (最初につくった押し出しのソリッドと ロフトでつなげたソリッドの2つ) ↓この状態の時です。   もし薄板を作っている時、 □ マージする というチェック項目を付けていたら 一体化しているので別のソリッドにはなっていませんでした。   このように、1つの部品ドキュメント内に複数のかたまりがあることを 【マルチボディ】といいます。     今回は「組み合わせ」というマルチボディ機能を使いたかったので このような作成方法を試してきましたが、 別々の部品ドキュメントに作ってアセンブリで構成することも出来るので、 可能な限りはアセンブリで作成することをオススメします。 それは、マルチボディで作るとかなり慣れた方でないと あとで修正などで手を加える作業の難易度が上がるからです。   得意なものが違うので、作りたい形状に合わせて マルチボディ・アセンブリを選択できるようになるといいですよね。    ...

【回転・ロフト・組み合わせ】スプーンを作ってみよう03

https://cadrise.jp/manual/so_manual/spoon02/ ご好評いただいておりますスプーンの第3弾、 あと少しで完成です! 前回のこの形までは出来ていますか?? 大事な設定をお伝えしていなかったのですが、 この押し出し-薄板フィーチャーの設定画面にある □ マージする のチェックは外しておいてくださいね。 マージしてしまうと本体のソリッド(かたまり)と 一体化している状態なのであとで抜き取れなくなります・・・   今日はひとまずここまでを目指します。 最初はすくう部分のつぼを作っていきましょう。 まずはスケッチですね。 ◆ポイント◆ ・エンティティ変換でレイアウトスケッチをコピーしますが、 先端を少しとび出させます。 (端点をドラッグでスケッチを伸ばせます。その後寸法入力!) ・真ん中のブロックのスケッチはレイアウトの中点までにしてください。 (また端点をドラッグで中点まで縮めます。 うまく縮められない場合は中点に作図線を引いてトリムでもOKです) ・上の図では分かりやすいようオレンジ色で出していますが、 回転の軸になるよう中心線をいれてください。   【回転 ボス/ベース】 上のような設定にします。 ※ここでも「結果のマージ」にチェックが入らないよう注意してください。 このような形になりましたか?↓↓↓ では、柄とつぼを「ロフト」でつなぎます。 この次にやる「組み合わせ」では 要素をくっつけて1つになっている必要があるので オプションのチェックに気をつけてください。 押し出しと回転の薄板を作成するところでは 「マージする」のチェックを外すようお願いしておりましたが、 ここではチェックを入れます。 ただ、チェックを入れるだけではやはり本体のソリッドも 一体化してしまいます。   そこで、設定画面最下部にある 「フィーチャーのスコープ」です。 デフォルトの状態では「自動選択」になっていますが、 チェックを外し、「選択ボディ」をチェック。 2つの薄板(↓の緑と青)を選択します。 こうすることで、本体はマージせず、つぼと柄をつなぐことができます。       できましたか? ここまでできれば、あとはこの2つの要素の重なっている部分だけを抜き出します。 挿入 → フィーチャー → 組み合わせ 要素がしっかり作られていなければ「組み合わせ」を選択できません。 その時は今までの過程をもう一度確認してください。 ブーリアン演算を使って共通部分だけを抜き出しています。 こちら、詳しくは検索してみてくださいね。 最後に柄の端をフィレットで丸めたら完成です! 3回にわたってお伝えしてきましたスプーン、如何でしたか? 一つひとつの手順は分かっていても、 こうやって曲面を作るのはまだまだ大変な作業だったのではないでしょうか。 引き続きみなさんのお役に立てる情報を発信してまいります。  ...

【レイアウトスケッチ】スプーンを作ってみよう02

  昨年末、↓でスプーンのスケッチ課題を出させて頂きました。 今回からは立体にしていきますよ! https://cadrise.jp/manual/so_manual/161227spoon/   早速作ってもらったファイルを開いてから続きをお読みください。   まずは今あるスケッチを押し出しフィーチャーで 厚み20mmの立体にします。   でも今のままでは折角キレイなスケッチが描けても、 キレイなスプーンにはほど遠いですよね。 スプーンを横からよく見ると、曲線で斜めにできています。 ですから次は、断面形状を作ります。       【課題】下図のようなレイアウトスケッチを作成してみましょう ※ヒント:スケッチコマンドで作ります。 寸法は3箇所だけですが、拘束によって形状は完全定義できます。 スケッチ出来ましたら名前を「レイアウトスケッチ」に変更しておいてください。 (ツリーの名前をダブルクリックすると編集できます)     これだけだと物足りない方もいると思いますので、 柄の部分もやっちゃいましょう。 先ほど作ったレイアウトスケッチを元に下図の形状を作ります。 変な形ですが、最後に「組み合わせ」で重なってるところだけ残す操作が入り、 ちゃんとスプーンになります。 スケッチは↓こんな感じ。(この拘束マークは?色々お試しください!) これを下記設定で押し出します。 ・スケッチ平面 ・中間平面 ・幅40.00mm ・片側に押し出し ・厚み1.00mm   さて、また次回に続きます。 次回はすくう部分(「つぼ」というんですね)の 丸みを「回転」を使って作り、 今回作った柄と「ロフト」でつなげます。 お楽しみに♪...

テンプレートの作り方

SOLIDWORKSに限らず、 沢山扱うものは毎回設定するのではなく テンプレートになっていた方が便利ですよね? ・単位(mmやインチ等) ・背景 ・文字サイズ(寸法等) ・面 ・軸 などなど。 毎回部品ドキュメントなど開いて背景色を変えて・・・ といったことをしてから実作業に入っている方には お役に立てる内容です。 デフォルト設定とは少し変えているんだけど、 よく使うものってあると思います。 そういったものはテンプレートにしてしまいませんか? まずはテンプレートへの保存方法です。 1.テンプレートにした設定を行います。 2.ドキュメントをテンプレートとして保存します。 メニューバー>ファイル>指定保存   3.ファイルの種類 Part Templates(*.prtdot)を選択します。   4.ファイルの保存先がデフォルトの 部品ドキュメントテンプレートが保存されている場所に変わります。     5.ファイル名に名前を指定して保存します。 ※ここで表示されている「部品」と同じ名前にするとデフォルトのテンプレートが上書きされます。 ※上書きしたくない場合には任意の名前をつけます。   6.開いている部品ドキュメントは必ず閉じます。 ※閉じずに作業をして間違って上書きしまうと、その内容までテンプレートになってしまうからです。   7.新規で部品ドキュメントを開くと先ほどの設定を保持した状態のファイルが開かれます。 ※5.で任意の名前を付けた場合には新規ボタンをクリック後、 「アドバンス」のボタンを押すと、任意に保存したテンプレートが表示されます。 **************** 背景・単位・文字サイズの変更方法 **************** 背景の変更 ここでは白背景に設定します。 1.ディスプレイマネージャーを開きます。 2.シーンを右クリックして「シーン編集」 3.背景を「グラジエント」にし、 上部、下部共に白で設定します。 ※その他ヘッズアップツールバーからも手軽に変更可能です↓ **************** 単位の変更 ツール>オプション>ドキュメントプロパティ>単位 **************** 文字サイズの変更 ツール>オプション>ドキュメントプロパティ>寸法  ...

【スプラインの使い方】スプーンを作ってみよう

  突然ですが、今日はスケッチ課題を出題します!   お題はこちら(画像クリックでPDFもダウンロードできます) スプーンのすくう部分をスプラインで描いています。 この部分をうまく作れるかがポイントですね。     ****************** 以下は回答になりますので、 この課題に取り組まれる方は後でご確認くださいね。   やり方、大きく分けて2通りあるかと思います。 1)中心線が描いてあるので上下どちらか半分だけ作って 「エンティティのミラー」で対称に作る方法 2)すくう部分のスプラインだけ一度にぐるっと描いてしまう方法   中心線があるので、1の方法で取り組まれた方も多いと思います。 どちらの方法でも作成可能です。 ただ、スプラインはカーブの制御が難しいので、 1回で描いたほうがより滑らかでキレイな曲線が描けます!     ですから、まずは2の方法をご案内しますね。 中心線を描いたら「スプライン」を選択。 ぐるっと描いてしまいます。 このとき、描き始めから終わりまでのクリックは5箇所です。 3回目のクリックは中心線の端と重ねてくださいね。 外形が描けたら拘束を入れていきます。 上図のように中心線に対して対称の拘束を付けます。 拘束の付け方は2点と中心線をCtrlキーを押しながら選択して、 左側に現れたメニューより「対称」を選択   次に寸法を入れます。 出来ました^^         ************** 次に1で作る場合 (スプラインの制御方法も入れてます。 また区切が分かりやすいよう、背景を変えました) 上半分だけ描いて、「エンティティのミラー」 このような形になりました。 お気づきになりましたか?先端。 これで食べたら痛そうですよね^^;   丸めていきましょう。 もう一度スプラインで描いた曲線をクリックすると 左側にメニューが出ます。 パラメータでも数値を変えられますが、 スケッチにも矢印が出現しています。 この矢印を「ハンドル」といいます。 この矢印をドラッグして向きや長さを変えることでも 曲線をコントロールできます。 (先端にある●と途中にあるダイヤマークでドラッグ可能です)   正解は無いのでキレイに見えるポイントを探してみてください。 (ぐるっと1回で描いた方がいいというのが、 分けるとこのように滑らかな曲線を作る操作が必要になるからです) いじりすぎておかしくなってしまった!という場合は 同じメニュー内の下に「全ハンドルをリセット」というボタンがあります。 そちらで初期値に戻ってやり直してください。     柄の部分はトライしてみてくださいね。 こちらは「エンティティのミラー」で作ります。     いずれ、これを肉付けして立体化するまでの 工程を追ったスプーン作成のシリーズにしますので、 出来たスケッチは保存しておいてもらえると幸いです。 ...

【スイープ】2016~の新機能

今日はSOLIDWORKS2016と2017で 進化している機能の1つをご紹介します。 【スイープ】です。 メールセミナーの 「よくわかる便利機能編 その1」 のSTEP3では螺旋形状のご紹介として コイルばねのような立体的螺旋形状の肉付けでも 使い方をご案内しています。。 コマンドでいうと、 『ヘリカルとスパイラル』 で螺旋のスケッチを作って、 【スイープ】で肉付けして作ります。 今までのバージョンでは、 【スイープ】は「輪郭となるスケッチ」と 「パスとなるスケッチ」の2種類が必要でした。 ですから、【スイープ】に必要な輪郭を描く為 螺旋の先端に垂直になる面を作って 円の輪郭をスケッチする必要がありました。 初心者の私には、 この「先端に垂直になる面を作る」ことが難しくて、 何度も試行錯誤してしまった部分でもあります。 では、2016からはどうなっているか? 【スイープ】コマンドを選択すると 輪郭とパスのところに新たな選択肢があります ○スケッチ輪郭 ○円形の輪郭 上のスケッチ輪郭を選択すると今まで通りです。 下の円形の輪郭を選択すると・・・・ 円の直径を入力するだけで 輪郭のスケッチが無くても肉付けできてしまうのです!! 円形であれば面の作成や スケッチの手間が省けて とっても簡単になりますよね。 (もちろん、先端も垂直になってます)     さらに! 今まで輪郭スケッチはそのスイープの 始点になっていたのですが、 パスがあれば両方向にも延ばせます。 パスの途中に輪郭を描いてもOKになっています。     さらにさらに! 2017からは、輪郭の指定が「スケッチ」だけでなく 「面」でもOKです。(スケッチ輪郭で面を選択します) すでに出来ているフィーチャーにパスだけスケッチして、 フィーチャーの面を輪郭に選択することでも 【スイープ】可能となりました。 どんどん便利に進化していってますね。  ...