SOLIDWORKS操作マニュアル

仮想線の表示設定

以前ご紹介したスケッチフィレットで、 仮想交点のつけ方についてもご紹介しておりました。 スケッチフィレットを使いこなす【仮想交点】     そして、このときに使っている仮想線についても、 表示方法が選べるってご存知でしたか?   例えば、このようにしっかり線を表示するものや、 下図のように点(星)だけで表示させることもできます。   これはお好みで変えることができます。 複雑な曲線を作ったら沢山の線があって わかり難いなという場合も 変更することでスッキリしますよ。   それでは早速設定方法です。 【ツール】→【オプション】→【ドキュメントプロパティ(下図)】→【寸法】→【仮想線】   設定できるのは プラス・星・補助線・点・なし の5種類。 選んだらOKをするだけで簡単に変わります。   お試しくださいね^^    ...

アセンブリ上で部品をミラーする

前回は「部品のミラー」についてご紹介しました。 勝手違いの部品を別ファイルで作れました。 ↓ ↓ ↓ 勝手違いの部品作り(エンティティ以外)   こちらは、単純に勝手違いの部品が欲しいときや、 部品のみの設計で完結するとき などに有効です。 部品が複雑だったり、組立の時には また違った有効なコマンドがあります!   「構成部品のミラー」 今回も前回と同じモデルでやってみます。 でも、今回はアセンブリドキュメントで開いてくださいね。 部品を置く場所はどこでもかまいませんが、 原点など合致をつけて配置すると、 ミラー後の部品も固定されてしまい動かせなくなりますので 配置も気をつけてくださいね。 (下図のように【(固定)】と入っているか どうかでわかります。)   さて、ミラーしたい部品を配置したら、 「構成部品のミラー」を選択します。 「構成部品パターン」内 または、↓「挿入」メニュー内にあります。     すると、左側にメニューが出現します。 ミラー平面やコピーする部品を選択してOKすると できました。   部品としては一つしか作成していませんが、 このようにミラーすることで2つ以上に増やしていけます。   こちらも部品のコピー同様、コピー元の形状と リンクしていますので、部品編集の際は注意が必要です。       ただ、今回のはもう少し編集が可能で、 リンクしないでミラーすることも可能です。   「構成部品のミラー」を選択して出てきたメニュー こちらを良く見ていただくと、 「次へ」ボタンがあります。 ここを進むと、 ・ミラー後部品の回転 ・新規ファイルとして保存 ・リンクを解除 といったことまで可能になります。 色々試してみてくださいね。  ...

勝手違いの部品作り(エンティティ以外)

「勝手違いの部品作り」に 役立つコマンドのご紹介です。 ブラケットなどの対称部品を作る場合、 どのコマンドを使って作りますか? 「エンティティのミラー」を 使っている方も多いかと思います。   でも、エンティティだと ミラーした元を消したりと 手順もかかってしまいます。 もう一つ、SOLIDWORKSには 部品をミラーする機能があります。 「部品のミラー」 こちらは別ファイルにミラー部品を作成するので 知っていると便利ではないでしょうか?       それでは早速使用方法について解説していきますね。 まずはミラーしたい形状を↑コレで解説していきます。 モデリングできたら保存します。(今回はそのままPart1としました。) 保存してから、ミラーする基準面を選択(青い部分)します。 (面選択をしていないとコマンドが使えません) この状態で「部品のミラー」をします。 コマンドの場所は、 「挿入」→「部品のミラー」   すると、新規ファイル(Part2)で 先ほど選択した面に対称な部品ファイルができます。   Part1は保存されていますが、 新しいPart2は保存されていませんので 保存を忘れず行ってください。 使用方法としてはとっても簡単ですよね。     ここからは、さらにこの機能の解説していきます。 ミラー部品は元部品とリンクしています。 ですから、保存後であっても元部品に穴を開ければ、 ミラー部品にも穴が開きます。 しかし! ミラー部品に穴を開けても、 元部品には開きません。 上記のように、元部品に施したことは全部 ミラー部品に反映されるようになっていますが、 ミラー部品に施したものは元部品には 反映されないので気をつけて使用くださいね。     今回は以上です! お役に立てましたら幸いです。    ...

スケッチフィレットを使いこなす【仮想交点】

今回はフィレットの第2弾。 「スケッチフィレット」について。 (弊社『SolidWorks練習帳』ミニカーなどでも 使用されるテクニックのご紹介) このような2つの直線のコーナーを 「スケッチフィレット」で スケッチの段階でフィレットをつけることができます。 ↓↓↓     でも、先にフィレットを入れてしまうと 寸法を入れる際に選択されるのは このように、フィレットの手前までの寸法になります。   ※先に寸法を入れてから「スケッチフィレット」すれば 上図のように入ります。 しかし、場合によってはこのような寸法を 後から追加したいケースもありますよね。     そんなときにどうしたらいいのかというと、 『仮想交点』を作ります。 2つの直線の仮想延長上の交点に点をうち、 寸法を拾える状態にします。   【方法】 1) 2つの直線をCtrlキーを押しながら選択します。 2)点コマンド 3) できました!   交点を選択できるようになります。  ...

『設計ばらし』って何ですか?

今日も諏訪圏工業メッセでお問合せを 貰った内容について回答します。 「『設計ばらし』って何ですか?」 弊社の行う業務内容を書いた中に 『設計ばらし』があり、 質問して頂きました。 (図面ばらし・バラシということもあります)     3D特有のもの、 というわけではありませんし、 どのような設計を行っても、 必ず『ばらし』の作業は発生します。     【ここで1つ補足】 設計にはボトムアップ設計と トップダウン設計の2種類があります。 ・ボトムアップ設計 部品ありきの組立設計。 あらかじめ個々の部品の詳細が決まっており、 部品から全体を組み立てていきます。 ・トップダウン設計 全体像の構想から作り上げ、 細部の部品形状を作りこんでいきます。     例えばトップダウン設計では 全体像(レイアウト)が 先に作られているので形状は分かります。 しかし、そのままでは部品1つひとつの 正確な形がわからず、 製作することはできません。 だから、部品1つひとつに『ばらし』て、 機械加工等できるよう寸法公差、幾何公差、 表面粗さ、表面処理などの 作業指示まで加えた図面を描きます。   ボトムアップ設計の場合でも 組立設計後に部品1つひとつに『ばらし』ます。     これが、『設計ばらし』です。       余談ですが、この作業は設計者が 設計から『ばらし』までやることもあれば、 専任の「CADオペレーター」が行うことも あります。 (求人などである「CADオペレーター」は このような図面にするのがお仕事です)     そんな『設計ばらし』をして 部品図を作成したら、 どの部品をどこに使うのかがわかるようになっている 「組立図」も作成します。 (こちらも組図ということも) 如何でしたか? 設計といっても 様々な工程がありますよね。...

客先からデータを受け取るには?(中間ファイル)

今日は中間ファイルについてお伝えします。 先日の諏訪圏工業メッセでのこと。 「使用CADは?」とよく聞かれました。   弊社はSOLIDWORKSをメインにしておりますが、 お客様では2D、3D様々なCADソフトの 名前が出てきます。 そうすると、お仕事をご一緒するには 「中間ファイル」での受け渡しに 関する知識が必須となります。   無料メールセミナーの基礎知識編でも 中間ファイルとは?から解説しています。 今回は客先から3Dモデルデータを 受け取るときの確認事項や モデルの状態について解説していきます。   ◆客先からデータを受け取る種類 データを受け取る形態は次の3つがあります。 1:紙図面 ・・・ファックスや郵送で届きます。3Dモデリングからスタート。 2:DXF、DWG(2次元CADデータ) ・・・電子メールやCDなど電子データで届きます。 1同様モデリングからですが、DXF、DWGを取込んで 仮想立体を作成できる為、紙図面より時間と労力が減る 3:3Dモデル ・・・電子メールやCDなど電子データで届きます。 モデリングの作業分の時間と労力が減る。 ※3の場合の「中間ファイル」について ◆客先から3Dデータを受け取るとき 自社の使用CADソフトと 先方のソフトが違うことは容易にあります。 そんなときもスムーズにやり取りができるよう 「中間ファイル」について知っておきましょう。 ◇確認しておくこと 1:自社のSOLIDWORKSは何なのか? SOLIDWORKS 20○○というバージョンにより 同じSOLIDWORKS同士でも開けない場合があります。 2:客先の3DCADは何なのか? 3:推奨する中間ファイルの出力形式 状況に合わせた種類の3Dデータを依頼します。 下記を参考にしてください。 ********************** ◆客先の3DCADと、 そのCADで推奨する中間ファイルの出力形式 (このファイルで貰えるよう依頼する) SOLIDWORKS  ・・・Parasolid Pro/ENGINEER ・・・STEP・IGES I-DEAS    ・・・IGES CoCreate   ・・・ACIS Unigraphics  ・・・Parasolid Solid Edge  ・・・Parasolid Inventor   ・・・ACIS CATIA V5   ・・・STEP ********************** ファイルについての詳しい内容や 保存方法についてはメールセミナーで 解説しておりますので、 よければこちらもご登録(無料)ください♪...

思うように動かないアセンブリの克服

本日はアセンブリで困った場合の対処法を2つお伝えします。     まずは先週から引き続いて机のレイアウトをしていた時のこと。 【部品の合致を反転させたい】 アセンブリで机を2つ出してきました。 この2つの机を【向かい合わせ】で配置したい と考えていました。 最初に2つの机を床と合致をつけます。 そして、机の奥の壁同士に「一致」をつけます。 あれ? 横並びになってしまいました。   向かい合う為には合致の向きを反転させたいです。 どうすればいいのでしょうか?     こういった場合は 左側の合致設定画面にあるボタン これを変えます。 向かい合わせになりました! 「一致」の他に「同心円」などでもこの整列状態の ボタンは出てきますので覚えておいてください。 ※今回床面との一致を入れてから回転させましたが、 合致の付ける順番や場所によってはこのように思わぬ方向に 回転してしまうこともあります。研究してみてください。   今回は「合致」を使って部品の向きを 変える方法をご紹介しましたが、 部品を挿入したときにマウスの左ボタンで ドラッグして部品自体を回転させる方法もあります。 部品点数が多い場合などは先に部品を回転させるのも有効です。     【部品が中に入って取り出せない!?】 大きい部品と小さい部品をアセンブリする時、 誤って小さい部品が中に入ってしまうことがあります。 確かに中にある・・・ でも選択ができないから取り出せない! どうすればいいのでしょうか?   取り出す方法は2つあります。 【方法1:外側を透明にする】 ツリーから外側の部品をクリックして コンテキストツールバーを表示。 「透明度変更」をクリック。 外側が透明になり、中の部品を選択できるようになりました。 【方法2:ワイヤーフレーム表示へ】 ヘッズアップビューツールバーから 「表示スタイル」を【ワイヤーフレーム】へ変更します。 ↓ 中の部品を選択できるようになりました。   如何でしたか? お役に立てる時があれば幸いです。...

内径が基準の箱を作るには?

こんにちは。アドライズの中澤です。 今回もSOLIDWORKS初心者の私が操作していて 分からなかった所を少しずつ解説していきますね。   そんな今日は、 「内径が基準の箱を作るには?」を お届けします。 今私は本社へ新入社員を迎える準備もしています。 しかし、今のままのオフィスでは席が用意できないので、 レイアウト変更をSOLIDWORKSを使って計画しています。 以前も先輩が行っていたので 部品(机やキャビネットなどの家具)はあります。 あとは部屋のサイズを測って箱を用意し、 その中にアセンブリで家具を設置するだけ。 こう書いてしまうと、とっても簡単に聞こえます。 でも、やってみると家具が多いため手数が多く、 アセンブリに関してもかなりのトレーニングになっています。 モノが分かりやすいので練習にオススメですよ。 さて、そこから私のつまずきポイント(笑) アセンブリの前に部屋を作る段階で止まりました。 作るにあたり、まず考えた方法は、 1:部屋の寸法を測る 2:そのサイズで矩形スケッチを描く 3:押し出しで立体化 4:シェルでくり抜く でした。 このような部屋であったり、収納用の箱を設計する場合などは 内径が基準になるものがあります。 でもこの方法だと内側のサイズが 厚みの分だけ小さくなり寸法がおかしくなります。 ここで一つ、考えが浮かびます。 「手順2を”実寸+壁の厚み”で スケッチを描いたらいいのではないか?」 確かにこれでも欲しい形は手に入りますよね。 でも、これでは図面通りではない上に、 設計変更が起きた場合なども対応できません。 ここでオススメなのがエンティティのオフセットです。 内径のスケッチを作図線で描き、 「エンティティのオフセット」で壁の厚み分の オフセットの距離を指定してスケッチを描きます。 (手順3・4は同じ。 作図線にしないと押し出し時に底抜けの筒になります。) この描き方をすることで内径(作図線の寸法)が 変わっても壁の厚みはそのまま追従します。 スケッチの寸法は、図面にする時にも 使われる寸法となりますので、 形が合っているだけでなく、 寸法の取り方にも気をつけて描いてください。 次回はアセンブリ時の”部品の回転”について お伝えします!お楽しみに...

設計に欠かせない「図面」を解説します

今月は図面についても見てきました。 最初のつまづきになりやすいポイントで 基本の部分だけでしたがいかがでしょうか? でもまだまだ奥が深いです。 メルマガやブログで簡潔的に説明するには 内容が膨大なのと、SOLIDWORKSの操作を中心に 解説していることもあってあまり表には出ていませんが、 弊社の「研修」ではたっぷりお伝えしています。     SOLIDWORKSは各社が行うスクールに通って 習得することが一般的ですが、 弊社ではご依頼頂いた会社様に講師が出張して (北は岩手県から南は熊本県まで出張開催実績有り) 3日間の研修を行っております。 もっと詳しく!という方はぜひそちらも 検討して貰いたいのですが、 費用や時間的に今すぐは厳しいと 感じるかもしれません。       弊社でも教育において費用や時間的拘束は 重要なボトルネックになっていることを実感しています。 ですからそれを解決する1つの手段として 【DVD】教材を紹介させてください。 ************* https://cadrise.jp/dvd/ ************* DVDでボトムアップ設計の基礎が学べるのは アドライズだけの商品です。 通常3日間(定価33万円)の研修を7時間の映像に 収めているので、好きな時間に毎日少しずつ、など 1人で自由に受講可能です。 私もヘッドホンして自分のデスクで学びました。   図面だけでなく、より効果的なモデリング方法なども 解説しておりますので、スキルのランクアップが狙えます。 研修後の復習教材としても最適ですよ。   「2次元から3次元へ移行する際の違いが解った」、 既に使っている人からも「知らないことも学べた」という ご感想もいただいています。 操作が動画で見れるから迷わないし、 分からない部分は戻って何度でも再生可能です。 サンプル動画なども載せていますので ご興味もって頂けた方はぜひ下記URLを ご確認ください。 ************* https://cadrise.jp/dvd/ ************* 講師は弊社社長の牛山です。...

線の真ん中で貫通拘束をかける方法

  貫通の拘束をかける方法について 詳しく解説をしていきます。   その前に、「貫通とは?」を確認しておきます。 貫通拘束では、「点と、異なる面にある要素が一致します」 https://cadrise.jp/manual/kousoku/ 貫通拘束を使うには、現在編集中のスケッチの【点】と 【異なる面にある線など】が必要になります。       例題: 上記の図のオレンジ線を下の3本の円弧に貫通拘束をつける 回答: オレンジ線の両端の拘束については、 オレンジ線の端点と下の円弧を選択することで 画面左側に「貫通」が出てきます。   しかし、オレンジ線の真ん中では? 貫通拘束を使うには、現在編集中のスケッチの【点】と 【異なる面にある線など】が必要になります。 つまり、オレンジ線の中点が必要になります。 そこで、オレンジ線の線上で右クリックをすると 下記のようなメニューが出てくるので、 「中点の選択」をします。   一時的に中点が選択状態になります。 (一時的な表示なので他のところをクリックすると消えてしまいます。) そのままCtrlキーを押しながら下の円弧をクリックすると 貫通拘束ができます。 **** 【端でも中点でもない任意の位置で貫通をかけたい場合】 任意の位置にスケッチの「点」をつけ、 その点と異なる面の要素を選択します。...