SOLIDWORKS操作マニュアル

エンティティオフセット

今回は【エンティティオフセット】についてご説明します。 【エンティティオフセット】とは既にある線をある一定の間隔(オフセット)で スケッチできる機能(コマンド)のことです。                 ↑上のように図をかいてみましょう。       ↑CommandManagerから「エンティティオフセット」をクリックします。                       ↑基となる線(ここではこの矩形です)を選択すると水色にハイライトします。                     ↑パラメータの線を「15.00mm」に設定してみます。 「寸法の追加」と「チェーン選択」にチェックが入っていることを確認します。                     ↑15mm外側にオフセットした線が追加されました。                 ↑同じように次は角丸の矩形を作ってみましょう。 寸法を「70」と「150」、「R20」と設定してみます。                     ↑エンティティオフセットをクリックし、基となる線を選択します。 今回は10.00mmを「反対方向」にもチェックを入れてみます。 すると先ほどとは逆に内側に線が追加されます。                       ↑「ボス押し出し」をします。                     ↑「エンティティオフセット」コマンドを活用する機会は多いと思うので しっかり覚えておきましょう。...

スケッチ駆動パターン

今回は【スケッチ駆動パターン】についてご説明します。   【スケッチ駆動パターン】とはスケッチ内のスケッチ点を使用して、 フィーチャーパターンを作成する機能です。   注意点として点のスケッチとパターンさせたいフィーチャーのスケッチが 同じ面で描かれていることが条件です。                         ↑ここにスケッチ駆動パターンを使い、脚を作って椅子を完成させましょう。                                         ↑椅子の脚がつく座板の裏側の面にスケッチを描き、押し出します。                           ↑脚を描いた座板の裏面に再度スケッチに入ります。 脚をコピーしたい箇所に点を打っていきます。 ここでは端面からそれぞれ15mmオフセットしています。                           ↑点のスケッチ面を選択したままCommandManagerの 「フィーチャータブ」→「直線パターン▼のタブ」→「スケッチ駆動パターン」を選択します。                 ↑「選択アイテム」に点のスケッチ、「パターン化するフィーチャー」には、 先ほど脚を作ったフィーチャーを選択します。                       ↑「OK」をクリックすると脚が3本追加されて椅子の完成です。      ...

USB007

干渉認識

今回は【干渉認識】についてご説明します。 干渉認識とはその名の通りアセンブリ内で干渉している箇所がないか、 調べてくれる機能になります。 一目で問題がある箇所が分かるので非常に便利です。     これはUSBのアセンブリです。 このアセンブリについて干渉箇所があるか確認してみましょう。 メモリ基盤、ケース(下側)、ケース(上側)の3部品から構成されています。 パッと見では干渉している箇所があるかわかりません。     ケースを透明にしてみます。 …しかし、まだわかりずらいです。       早速干渉認識してみましょう。 CommandManagerの中に評価タブがあります。 その中に干渉認識があります。       選択構成部品に調べたいアセンブリを入れて「計算」をクリックします。     すると結果が表示されます。 5箇所干渉しているようです。     モデルを見ると赤くなっているところがあります。 ここが干渉箇所です。     5箇所全て選択すると図のようになりました。 ケース(下側)のピンが干渉していることがわかったので修正します。     今回は図のように設計変更しました。     再度干渉認識をして、干渉箇所が無くなったことを確認できました。 ...

シェル01

シェル

早速ですが、図のモデルはどのように作ったものでしょうか。 少し考えてみてください。   では正解例になります。 まず図の直方体を作ります。   次に不用な分をカットします。   最後に【シェル】を使うことで最初のモデルを作りました。 いかがでしたでしょうか? ピンと来る人はすぐ来たかもしれませんね。   今回はこの【シェル】についてお話します。 シェルはモデルを空洞化、薄板化する際に使います。 なので板金物を作る際には非常に便利な機能です。 使用方法はフィーチャータブの【シェル】をクリックし、 板厚、削除する面を入力します。 外側に厚みを付けたいときは外側にシェル化にチェックを入れます。   多用するフィーチャーになるかと思いますので、 しっかりマスターしましょう。...

パース表示

今回は【パース表示】についてご説明します。 パース表示とは、人間の目からみた「通常見えるビュー」です。 水平線が消失点に向かって短くなっていきます。 モデルをより立体的に表示できるので、覚えておくとよいでしょう。 ↑パース表示をしたもの(左)としていないもの(右)です。   ↑パースは「表示」→「表示タイプ」→「パース表示」を選択します。   ↑パースのプロパティは、パース表示にしてから 「表示」→「表示コントロール」→「パースプロパティ」を選択します。   ↑焦点からの距離を変更できます。...

表示方向

今回は【表示方向】についてご説明します。 【表示方向】は特定の角度に設定することも出来、非常に便利な機能です。   ↑上の図のように、普段の表示は「等角投影」か「不等角投影」が多いと思います。 この図を特定の角度に設定し、必要に応じていつでもその設定した角度で 見られるように設定していきましょう。   ↑まずCommandManagerの表示から、表示コントロール→表示方向をクリックします。 (または、右クリックで【表示方向】をクリック)   ↑既に設定してある表示方向にしたいときは、ダブルクリックします。 たとえば「左側面」をダブルクリックしてみると、上の図のように表示が切り替わります。   ↑新しいオリジナルの角度を設定します。   ↑表示方向の左上の「新規表示方向」をクリックし、新しい表示方向を登録します。 ここでは「角度A」とします。   ↑「角度A」が登録されました。「角度A」をダブルクリックしてみると、新規設定した角度になります。...

SOLIDWORKSのグレードについて

SOLIDWORKSのグレードの違いについてのご説明です。 【SOLIDWORKS Standard】→オプションのないグレードになります。3次元CADとしての機能は全て含まれているため、設計業務のみであれば機能は充分です。 【SOLIDWORKS Professional】→主に、部品ライブラリー、データ管理、写実的レンダリング、アニメーション作成機能などのオプションがついています。 【SOLIDWORKS Premium】→最上級グレードProfessionalのオプションに加え、強度解析(CAE)、動作解析、配線設計などのオプションが追加されます。   正確な製品マトリクスについてはメーカーホームページをご覧ください。 http://www.SOLIDWORKS.co.jp/sw/products/10198_JPN_HTML.htm...

DXF/DWGの挿入

今回は【DXF/DWGの挿入】についてご説明します。 【DXF/DWGの挿入】は客先から図面を頂き、それを参考に設計したいとき等に便利です。 今回は上図の図面を挿入したいと思います。 新規部品ドキュメントから入ります。 スケッチを入れたい面を選択します。今回は「正面」にします。 メニューバーから挿入→DXF/DWGをクリックします。 すると図の画面が立ち上がります。「次へ」をクリックします。 単位が「Inches」になっていることが多いのでそういった場合は「Millimeters」にします。 挿入するレイヤーを選びます。ファイルが重いときは必要なものだけ選びましょう。 プレビュー表示されているので確認しながら選択できます。 今回はここでは特に設定を変えません。 DXFファイルを挿入できました。 スケッチを終了します。 これを部品としてアセンブリに組み込んだり、 レイアウトスケッチとして参照しながらモデリングしたり出来ます。  ...

Instant3Dの活用

今回は【Instant3D】についてご説明します。  【Instant3D】は手早くフィーチャーなどの寸法を修正するのにとても便利です。   Instant3Dは、フィーチャーに沿った定規を表示させ、 フィーチャーをドラッグして寸法値を変更できる機能です。   定規が表示されるので、目的の寸法値までドラッグする方法もありますが、 ここでは、数値を入力して、ダイレクトに寸法編集をする方法をご紹介します。   ↑緑の円柱の長さを30.00mmから10.00mmに変更するとしましょう。   ↑CommandManagerのフィーチャー欄の【Instant3D】をクリックします。   ↑【Instant3D】が選択されたままこの緑の円柱をクリックすると 設定していた寸法が出てきます。   ↑変えたい寸法をクリックするとその寸法にハイライトがつき、変更可能になります。 30.00mmから10.00mmに変更します。   ↑「10」と打ち込むだけで、簡単に円柱の長さが変更されました。...