マニュアル

図面にロゴをコピーして貼りつける-DXF_SOLIDWORKS

前回のSOLIDWORKS操作マニュアルでは 企業やブランドのロゴの 図を挿入する方法 をご紹介いたしました。 記事はこちらから → 図面にロゴを挿入する-図_SOLIDWORKS   今回は図面シートフォーマットに、企業やブランドのロゴの DXFデータをコピーして貼りつける方法 をご紹介いたします。 完成図はこちら   操作方法 ファイル形式がDXFのロゴを挿入します。 まず、AutoCADなどの2D-CADでDXF ファイルを開きます。   コピーして貼りつけたいエンティティ(今回はロゴ)を選択し、クリップボードにコピーをします。 (AutoCADではCOPYCLIPコマンド、ショートカットキーは、 Ctrl + C です。)   SOLIDWORKSでコピーをしたエンティティ(今回はロゴ)を貼りつけるための 図面ドキュメントを開きます。 ※AutoCAD のDWGまたはDXFファイルは、SOLIDWORKSの 部品、アセンブリ、図面ドキュメントにエンティティをコピー&ペーストできます。   今回は図枠と同じシートフォーマットにロゴを挿入したいため、 シートフォーマットタブから「シートフォーマット編集」をクリックし、 シートフォーマットの編集に入ります。   メニューバー →編集 →ペースト を選択し、貼り付けます。 (ショートカットキーは、 Ctrl + C です。)   図面上にロゴマークが貼りつきました。 (ロゴはブロックとして貼りつきます。)   もう一度「シートフォーマット編集」をクリックし、シートフォーマットに編集に入り、   ロゴをドラッグして位置や、 PropertyManagerの パラメータ - ブロックスケール で大きさを変更します。   「シートフォーマット編集」をクリックし、シートフォーマット編集を終了します。   ぜひお試しください。   ...

図面にロゴを挿入する-図_SOLIDWORKS

大半の企業はオリジナルの図枠を保持しています。 そこで今回は、図面シートフォーマットに 社名やブランドのロゴを挿入する方法をご紹介いたします。 ※SOLIDWORKSの図面ドキュメントでは図枠のことをシートフォーマットと呼びます。 完成図はこちら     操作方法 シートフォーマットタブから「シートフォーマット編集」をクリックし、 シートフォーマットの編集に入ります。   こちらのロゴマークを挿入します。(ファイル形式は.jpegです。)   メニューバー →挿入 →図 を選択します。 ※このコマンドでは、図 (.bmp, .gif, .jpg, .jpeg, .tif, .tiff, .wmf, .png, .psd) を挿入できます。   ダイアログボックスが現れます。 挿入したいファイルを選択し、「開く」をクリック。   スケッチ図PropertyManagerが表示され、図面上にロゴマークが挿入されます。   下記を使用して図をドラッグしてロゴマークの大きさを調整します。 ■スケッチツールを使用 スケールツールは、図のサイズの変更に使用する各端点にハンドルがある作図線のことです。 ■アスペクト比固定 選択すると縦横比が固定されます。 図を配置をしたい位置にドラッグして移動します。 (ポインタが十字矢印のときに移動できます。) 大きさと位置が決まったら、「OK」ボタンをクリック。   ロゴマークが挿入できました。   シートフォーマット編集を終了します。   まとめ さらに、テンプレートで保存をしておけば、ロゴマークの入った図面を雛形として使用できますね。 ファイル →指定保存 →図面テンプレート(*.drwdot)で保存をします。 また、オリジナルの図面テンプレートの作成方法は下記の図面教材でご紹介しています。 ご活用いただけましたら幸いです。 ■書籍「よくわかる3次元CAD SOLIDWORKS演習 図面編」 ■DVD「よくわかる!SOLIDWORKS図面3 【設定編】」 ...

図面に用いる線の太さを変更する_SOLIDWORKS

日本の機械図面は概ねJIS規格を基準にしています。 図面に用いる線は線の形状と太さによる種類があり、これらを組み合わせて使用します。 ――――――――――――――――――――――――――――――――――――――――― 線の形状: 実線・破線・一点鎖線・二点鎖線 線の太さの種類: 細線・太線・極太線 太さの比率: 1:2:4 太さの基準: 0.13mm,0.18mm,0.25mm,0.35mm,0.5mm,0.7mm,1mm,1.4mm,2mm ――――――――――――――――――――――――――――――――――――――――― 太さの使用例として、 細線を0.25mmとした場合、太線は0.5mm、極太線は1mm。 また、線の形状は用途によって規定されています。 例えば、品物の外形を表す外形線は太い実線というように。   ところが・・ SOLIDWORKSのデフォルト設定では、細線が0.18mm、太線が0.25mmです。 比率は、1:1.388‥  図面に表すものの形状によっては用途の区別がつきにくいですね。 そこで、線の太さを変更する方法のご紹介です。 今回は、SOLIDWORKSの図面ドキュメントで、外形線の太さを0.25mmから0.35mm に変更します。   線のフォント   メニューバーから「オプション」をクリック。 システムオプションのダイアログボックスが開きます。 タブを「ドキュメントプロパティ」に切り替え、「線のフォント」をクリック。 エッジのカテゴリから「可視エッジ」を選択します。 「線の太さ(H):」をプルダウンから「0.35mm」に変更し、 「OK」をクリックしてダイアログボックスを閉じます。 ※可視エッジ=SOLIDWORKSでは外形線です。 ※今回は関係ありませんが、スタイル(S):=線の形です。   外形線の太さが変わりました。   変更後   変更前 この方法は、既に書き上げた図面にも有効ですよ。 お試しください。   ...

3Dモデルにサイズ公差を入れる_SOLIDWORKS

3Dモデルでサイズ公差を確認するときは どのようにしていますか? 紙図面や2D図面からモデルを作成した場合は 図面を見て確認していると思いますが、 「3Dモデルに入っていれば便利だな」 と感じることはありませんか?   そんなときに有用なのがこちら▼ ――――――――――――――― 「公差/少数位数」 ―――――――――――――――   さっそくサイズ公差を付記してみましょう 今回は、穴基準はめあい方式の軸の許容差を入れます。 基準寸法に軸の公差クラスと許容差の数値が付加します。 まず、モデルに付加した寸法を表示します。 ※現在は図示サイズ(基準寸法)のみでサイズ公差は入っていません。 公差を入れたい寸法「φ8」をクリックし、選択状態にします。 PropertyManagerの「公差/少数位数」を開き、   「公差のタイプ」に「はめあい公差」を選択します。   「軸基準はめあい」にプルダウンリストから「g6」を選択します。   「括弧で表示」のチェックボックスにチェックを入れ、プロパティを閉じます。   これでサイズ公差を入れることができました。 寸法を表示すると、基準寸法の次に、軸の公差クラスと許容差の数値が付加されています。   まとめ いかがでしたでしょうか。 モデルにサイズ公差を入れておけば、設計途中でも簡単に確認ができ、 流用設計の際もわかりやすいですね。 また、このモデルから図面を作成した際にも モデルアイテムで寸法を挿入すると 寸法軸の公差クラスと許容差が自動的に入るので使い勝手がいいですよ。 ぜひ試してみてください。 ...

モデルに材質を設定して重量を測定する_SOLIDWORKS

モデルを作成していく過程で、 このモデルを実際に製作したらどのくらいの重さなの? と思ったことはありませんか? 技術計算が速やかにできることは体積情報を持つ3Dモデルの醍醐味です。 そこで今回は次の2つの方法をご紹介します。 ――――――――――――――― 1. モデルに材質を設定する方法 2. モデルの重量を確認する方法 ―――――――――――――――   使用するコマンド ・材料編集 (FeatureManager デザインツリー) ・質量特性 (評価タブ) - - - - - - - - - - ※今回モデルに設定する材質には、SOLIDWORKSにあらかじめ登録されている材料を使用します。  そのため、重量についてはあくまでも参考値となります。  実際に使用する材料での正しい重量が知りたい場合は、その材料の物性値で材料を登録する必要があります。 - - - - - - - - - -   1. モデルに材質を設定する方法 材料を指定していないモデルは、「材料<指定なし>」となっています。 FeatureManager デザインツリーの「材料」を右クリックし、メニューから「材料編集」をクリック。   すると、「材料」ダイアログボックスが表示されます。   今回は、材料に「炭素鋼(普通)」を設定します。 「Solidworks materials」フォルダを展開し、「鋼鉄」フォルダを表示します。   さらに「鋼鉄」フォルダを展開し、項目内の「炭素鋼(普通)」を選択します。 選択が出来たら「適用」をクリックし、「閉じる」をクリックします。   FeatureManager デザインツリーを確認すると、材料適用され「炭素鋼(普通)」に変わっています。     2. モデルの重量を確認する方法 評価タブから「質量特性」コマンドを選択します。 すると、「質量特性」ダイアログボックスが表示されます。 「質量」を確認すると設定した材質での重量がわかります。 重量のほかにも体積や重心なども確認できます。   また、単位がグラムのままでわかりにくい場合は、下記方法で変更することもできます。 質量の単位の変更方法 ここでは、グラムからキログラムの表示へ変更します。 ① ウィンドウ右上の「オプション」をクリック。 ② 「ユーザー定義設定を使用」にチェックを入れる ③ 質量の単位を「キログラム」に変更し、OKをクリック。 質量の単位がキログラムに変更できました。   まとめ いかがでしたか。 今回は、材質の設定と重量を確認するお話でした。 またの機会に、”物性値を設定して材料を登録する方法” をご紹介します。 是非お試しいただけましたら幸いです。 ...

中空のシェルモデル

  「シェル」フィーチャーは、 3Dモデルの外面から指定した厚み分を残して、 均一にくり抜くコマンドです。 外装部品、板金部品などの板厚が均一なモデルを 作成するときに便利なコマンドですね。   このような箱形状を作成する際に使用します。   ところで 「シェル」フィーチャーを行ったのに 形状がかわらなかった場合はありませんか?   SOLIDWORKSの入門講座でよくある現象ですので 今回、皆さんと共有したいと思います。   シェル このような場合 あれ・・・おかしいな・・と思い もう一度シェルコマンドを行おうとすると 下記のようなエラーメッセージが現れ適用できません。   これは、既に 内側が指定した厚みで中空になっている からです。 一見するとわかりませんが、 断面表示にして確認すると空洞化しています。   なぜ? この原因は、削除する面が選択されていないからです。 既存のシェルフィーチャーに「フィーチャー編集」に入ると 「削除面」に何も選択されていないことがわかります。   まとめ シェルコマンドで削除面を選ばなかった場合は、 中空の形状ができます。 モデル作成の過程で敢えて中空にすることもありますが、 通常は、削除面を選択して使用します。 エラーメッセージが現れた場合は、 フィーチャー編集に入って設定を確認してくださいね。   ▼関連記事はこちら ●シェル ●分割ライン②  ~分割ラインフィーチャーの活用~ ...

ノックピンの位置決め穴の作成方法

機械や装置の心出しや位置決めにはノックピンを使用しますが、 みなさんはどのように位置決め穴を作成していますか。 穴を「押し出しカット」コマンドで作成して、 図面を作成した場合は下図のようになります。 この場合、ダウエル穴記号は 「ダウエル穴記号」コマンドで手動で追加しなければいけません。 ですが、モデル作成者とは別の人が図面を作成する場合、 通し穴なのか位置決め穴なのかは3Dモデルからは判断できませんよね。 今回は、そんな際におすすめのコマンドをご紹介します。   穴ウィザード(ダウエル穴) まず、位置決め(ノックピン)穴を作成するモデルを開きます。   穴を作成します ① 穴を追加したい面を選択 ② 穴ウィザードをクリック   ③ 穴ウィザードのPropertyManagerに変わります。 「タイプタブ」で、穴タイプのパラメータを設定します。 ーーーーーーーーーーーーーーーーーーーーーーーー ※ 詳細項目にて下記を選択します。 穴タイプ:穴 規格:JIS 種類:ダウエル穴 ----- 穴の仕様へ設計値を選択 サイズ:φ5.0 (今回は「 φ5H7 」を選択) ----- 押し出し状態:全貫通 ーーーーーーーーーーーーーーーーーーーーーーーー   ④「位置タブ」に切り替えて、穴位置を決めます。 OKをクリックして穴をあけます。   穴あけ作業としてはこれで終わりです。 モデルを一見するといつもと同じ穴ですが・・・   図面を作成すると・・・ 図面ビューにダウエルピン記号が追加されています。   まとめ 「穴ウィザード」コマンドで穴タイプの種類に「ダウエル穴」を選択すると 図面ビューの作成時にすべてのダウエルピン記号を自動的に作成できます。 是非、ノックピンの位置決め穴をあける際にお試しください。   また・・・ 「押し出しカット」コマンドで作成した穴の図面にダウエルピン記号を挿入するには、 メニューバー/挿入 →アノテートアイテム →「ダウエル穴記号」です。 ...

拡大/縮小のマウスホイール操作を反転する

デフォルト設定は・・ 拡大/縮小はマウスのホイールボタン(中ボタン)で行います。 デフォルトの操作は、マウスポインタのある位置を中心に、 ・奥に転がす  → 縮小 ・手前に転がす → 拡大   今回は、他種アプリケーションをご使用の方で、 “拡大と縮小を思うようにコントロールできない” という方にご覧いただきたい マウス操作を下記のように反転したい場合の変更方法です。 ・奥に転がす  → 拡大 ・手前に転がす → 縮小   変更方法 メニューバーからオプションをクリック。   システムオプションタブ → 表示 から、 「マウスホイールによる拡大/縮小を反転」にチェックを入れ、「OK」をクリックします。 ※デフォルトではチェックが入っていません。 ※システムオプションはPCに依存する設定です。 SOLIDWORKSを終了して次回起動したときにも有効です。   設定が変更できました ・奥に転がす  → 拡大 ・手前に転がす → 縮小 これで操作性が上がる方もいらっしゃるのではないでしょうか。 お試しください。...

表示パネルで作業効率アップ!

表示パネルとは 「表示パネル」を使用すると、部品、アセンブリ、図面ドキュメントで 設定をした様々な表示設定をすばやく確認することができます。   前回は、部品を透明化する方法をご紹介しました。 →アセンブリで部品の透明度の変更する しかし、複数の部品を透明にしていくと、 どの部品を透明にしたのかわからなくなる場合があります。 そこで、「透明化した部品を確認する方法」を例に、 「表示パネル」をご紹介します。   表示パネルを使ってみよう 「表示パネル」はデフォルトでは折りたたまれています。 そこで、表示パネルを展開します。 FeatureManager デザインツリー上部のタブの右側にある > をクリック。 ※表示パネルを折りたたむには < をクリックします。   透明化した部品は、「透明度」の列にアイコンが表示されます。   現在、サブアセンブリ「コンテナ組立」は透明化をしています。   透明化を解除するには、「表示パネル」の解除したい部品や サブアセンブリの行のアイコンをクリックします。   透明度アイコンが消え、   モデルの表示が元に戻ります。   まとめ また、「表示パネル」では、透明度の他にも 非表示/表示、表示モードや外観なども確認できます。   中でも、 非表示/表示 の設定は、 アイコンをクリックするごとに 素早く部品やボディ、スケッチ、平面などの 非表示と表示の切り替えができ、とても便利です。 ぜひお試しください。 ...

アセンブリで部品の透明度の変更する

アセンブリドキュメントで 他の部品の影に隠れた部品を移動したいときや、 隠れた部品の位置関係を確認したいときに 手前の部品を透過したくなりませんか。 今回ご紹介する方法は次の場合に有効です。 ・装置のカバーを設計したら中身が見えなくなってしまったとき ・ある部品の中に入っている部品を選択したいとき ・材質がガラスや透明樹脂などの場合にそれらしく見せたいとき   部品の透明度の変更 使用するモデルは、 弊社書籍「よくわかる3次元CADシステムSOLIDWORKS入門」に 掲載のアセンブリモデル「コーヒーミル」です。 この「コーヒーミル」のアセンブリドキュメントを使用してご紹介します。 【部品の透明化】 【サブアセンブリの透明化】   【部品の透明化】 まず、アセンブリで使用している部品「ホッパー」を透明に変更します。 透明にしたい部品をクリックします。   すると、コンテキストツールバーが現れます。 「透明度変更」をクリックします。   部品「ホッパー」が透明になりました。 ホッパーを透明にしたことで、内部のミル刃の詳細な様子が確認できます。   【サブアセンブリの透明化】 次に、アセンブリで使用している サブアセンブリ「コンテナ組立」を透明に変更します。 FeatureManager デザインツリーからサブアセンブリ「コンテナ組立」をクリック。 コンテキストツールバーから「透明度変更」をクリックします。 ーーー サブアセンブリ品は、選択しているものが サブアセンブリなのか、部品なのかを混同しやすいので、 FeatureManager デザインツリーからの選択をお奨めします。 ーーー   サブアセンブリ「コンテナ組立」全体が透明になります。   注意点 透明度変更をするとその部品の面を選択し難くなります。 その際は以下の方法をお試しください。 ・Shiftキーを押しながら透明にした部品の面をクリックする ・透明にした部品の背後に何も部品がない状態にして透明にした部品を選択する 次回は、透明化をした部品を確認するのに便利な機能、 「表示パネル」をご紹介します。...